Library Showing as Empty

Hi, I’ve been using OSMC and Vero for a few years, and it’s always been a happy relationship.

When I logged in today, my TV and Movies sections are empty, with the message “Your library is currently empty…”. When I navigate to the files section, I can get to all of the media, and they all play fine.

Synology NAS for media, and sql library

Navigating to the sources, I noticed that the content type is empty (both TV and Movies). I set the content type, and when prompted said YES to a refresh - but it doesn’t refresh. Also, when I go into the content type subsequently, it’s blank again.

It might be synology playing up, but if anyone can point me in the direction of things to check it would be greatly appreciated.

Thanks in advance

First try to reboot. If that doesn’t do it take a look at your connection to MySQL

ERROR: Unable to open database: MyVideos116 [1129](Host '' is blocked because of many connection errors; unblock with 'mysqladmin flush-hosts')

If it can’t connect to the database it falls back to the local sqlite database which would normally be empty.

ERROR: Unable to create new database
NOTICE: Running database version TV32

Unrelated, but the other common cause of empty libraries is cleaning when the network connection goes down. You may want to consider removing that option from your advancedsettings.xml.


Thank you so much. For others, if they have a similar problem, I rebooting the Synology a couple of times solved for me.


1 Like

Sorry to resurrect this thread, but I have a similar issue and thought worth putting here to keep things together.

I unplugged my Vero 4k+ accidently. Plugging back in a few hours later it was saying library is empty. My Vero runs the MySql db locally and the media is stored on a USB drive also attached locally. What’s interesting is all the services and shares are up and running and my various FireTV devices are connecting to the SQL library and shares on the Vero without issue.

Locally on the Vero the shares are still mounted and can play media from the sources section, just seems to be having a problem suddenly at connecting to the local SQL library. I’ve checked the advanced settings and sources files on the Vero and all still find, so an odd one.

Any ideas? Note all Kodi devices, including the Vero, point to the sql libray and sources via the Vero IP address. Never had this problem before.

EDIT - I might have 4K not 4K+, can’t remember, have had it pushing 2 years.

Update for anyone else with a similar issue, not sure if this is something I’m going to have to now do every time after a hard power reboot or just a one off. But doing various power offs and soft resets still didn’t help. But I SSH’d to the Vero and ran the following command to restart kodi without bouncing other services and that resolved the issue.

sudo systemctl restart mediacenter

Do you have Wait for Network activated in MyOSMC - Network?

I think if you go to the power menu in Kodi and use the exit option you will get the same result without having to mess with ssh (Kodi will close and then reopen after a number of seconds). Sounds like Kodi is coming up before the database has finished loading. If the suggestion fzinken provided doesn’t work another possible workaround may be to go into settings>profiles>general> and enable show login screen at startup. Since Kodi doesn’t actually try to connect until it loads a profile this will allow you to always extend out the delay when you reboot.

I did try the exit Kodi option but didn’t work.

I do have the wait for network and I semi-regularly have to unplug the Vero and plug back in as sometimes video output doesn’t wake up, but never had this issue until now.

Next time I have to unplug I’ll see if it happens again and if needed test the login screen idea. Will post back, thanks guys.