Library titles showing in webGUI not in OSMC

I have a couple of files that are showing in the WebGUI with artwork and can be selected to play from here. When I go onto OSMC direct via the TV and HDMI cable the titles are not showing here. I had one that showed for a couple of days and has now dissapeared with no change to any storage etc.

The issue you are currently experiencing with OSMC

Some files are showing in the webGUI but not in the Kodi interface direct.

What you were doing when this issue occurred

Browsing for files.

Whether you can replicate this issue on demand. If you can, then please provide some steps on how an OSMC developer can reproduce the same issue.

Visit localIP:8080, clikc movies, see files.
go onto Kodi interface via direct cable, click movies - dont see files.

The device you are currently running OSMC on

What peripherals are attached to the device?
monitor, USB drive, wireless keyboard.

Has this issue been introduced by a new version of OSMC? When did the issue first appear and can you recall a time when it was not present?

dont know, files are added frequently as are updates.

Did you scan the folders into the library?
Do you have options checked like “one file per subfolder” or something?

Are you browsibg the library view or files view on the webinterface or on kodi itself?

Posting debug enabled logs that demonstrate the problem would be very useful.
Please refer to the linked article in my first post for reference.

Folders auto scan every couple of hours. One of the files actually showed up yesterday and then disapeared today. I dont think I have that one file per subfolder clicked, but each movie is in its own folder and i have hundreds. They all work fine.

I have browsed by both webGUI and on kodi itself. It works on the WebGUI and i can even play from here. Just doesnt show on Kodi.

I am not at the kodi box at the moment so cant post a debug log.

Can you see the files if you browse in videos->files instead of the library (movies)?
If so, do they have their scraped content attached or is only the filename showing?

No it does not show here at all. I can see it via SSH and the WebGUI though.

I do have 2 here that show but do not have artwork. I have queried what the bare minimum NFO is that I need in order for an effective scrape on these titles

You can also try to remove the folders with the problematic files from the library and readd / rescrape them.

So they do bot even show up in the kodi file explorer, correct?
Can you please also provide mediainfo for those files?

When you say remove them and rescrape them, would:

sudo mv filename filename_temp and then reboot and move back do, if not what do you mean move and readd?

They show up via SSH or in Kodi WebGUI. They do not show up in the library when using my Pi in my TV or in video>files>linked location

What is mediainfo? the NFO?

Pkease just read the link I posted earlier. There is information on how to produce logs and mediainfo.

With remove and readd I mean that you remove the mediasource for the library you added in kodi and add it again.

Probably it would be a good Idea for you tobread a bit in the kodi documentarion to get an understanding of how the library in kodi works.

mcobit - thanks for all the assistance.

logs - as I mentioned, not on the box at the moment so cannot create. Will do when home.

kodi library - read the documentation on this as the first point of contact. Its useful but I have been using the kodi library for a long time and it works about 98% of the time. I am happy with naming conventions, locations and happy with the NFO requirements as per the documentation. Only coming here to ask a few questions that the documentation doesnt answer clearly.

We believe this is a Kodi issue and as such you should look at addressing the issue there. We are unable to resolve your issue. If you do believe that this is an OSMC specific issue, please let us know.

SOLVED It wasnt a Kodi or OSMC issue…the user may have cliked ‘hide watched’. Unclicking this and it all worked normally.

1 Like