Linux backend with KWorld UB435-Q V3 USB ATSC TV Tuner

(Sorry if this may be somewhat off-topic, but there is so much Linux wisdom in here, I though I would try and take advantage of it :wink: )


First off, I have OSMC running beautifully on a RPi 2. I managed to get it installed, set its fixed Wi-Fi IP, etc. thanks to all your kind help and great work. I can’t wait for “stable” versions, though I find Alpha 4 quite stable already.

My setup is almost perfect now, and all I need to add is Live TV + recording capabilities, which I want to do with a Tvheadend or MythTV backend on a separate machine. My plan is to use an old machine and install Ubuntu 14.04 or 14.10 to use it with the Kworld UB435-Q V3 TV Stick.

Interestingly enough, that stick works not only on a Win 7 laptop, but also out-of-the-box on the RPi2 / OSMC.

Sadly, I have not managed to make it work on the backend Ubuntu machine. I upgraded the kernel to >3.16, and the USB device seems well recognized according to dmesg. (My output is the same as the V3 here: http://linuxtv.org/wiki/index.php/KWorld_UB435-Q_USB_ATSC_TV_Stick )

I can scan and lock channels/services/muxes, and both MythTV and Tvheadend detect my local frequencies/stations (tried both backend software pieces separately, not running concurrently). I can even get some OTA EPG to show up on the Pi’s OSMC interface, so I am definitely receiving something. The device’s red LED will light up when tuned to an actual channel.

So it all looks like it would work, but…

…unfortunately, when I try to watch the remote feeds (any channel/service), the picture is unrecognizable (big colored patches with some bizarre pixelated spots), sound is just a digital buzz and eventually the feed cuts off because there are too many errors. Am I missing something ? (Codec ? Firmware ? …?)

P.S. Again, the USB device works fine when re-plugged in Windows or directly on the RPi2, so signal reception or antenna placement is not an issue.

Thanks !

Try to install these packages:
http://packages.ubuntu.com/search?lang=en&keywords=v4l-utils

  • Can you try building an out of tree module?
  • Did you install any firmware? I recommend you try latest TV firmware. You could try OSMC’s firmware (bit of a hack):
sudo -s
wget http://apt.osmc.tv/pool/main/d/dvb-firmware-osmc/dvb-firmware-osmc_1.0.1_all.deb
dpkg -i dvb-firmware-osmc*.deb

S

Thanks for the suggestion. Not sure what to do next (?) Is there a config utility I should try to run ?

@sam_nazarko

Thanks Sam. I am not too familiar with “out-of-tree” modules. On a different hard drive (same machine), I had installed pure Debian and did try to compile a custom 3.19 Kernel, adding all the devices I thought were needed (in particular, the firmware for em28xx USB devices). No success there either.

As for your second suggestion, which looks potentially promising, I got:

(Reading database ... 180421 files and directories currently installed.)
Preparing to unpack dvb-firmware-osmc_1.0.1_all.deb ...
Unpacking dvb-firmware-osmc (1.0.1) ...
dpkg: error processing archive dvb-firmware-osmc_1.0.1_all.deb (--install):
 trying to overwrite '/lib/firmware/v4l-cx231xx-avcore-01.fw', which is also in package linux-firmware 1.138
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 dvb-firmware-osmc_1.0.1_all.deb

Any clue on how to circumvent this ?

Regards,

…some more questions maybe related to how Raspberry / OSMC manage USB ports.

My tuner card is said (per this reference) to support (only ?) “bulk mode”, which has been interpreted by some as USB 3.0 (like this site here: Digital Tuner Cards - MythTV Official Wiki )

Is there something I could do with my Ubuntu to update the USB firmware / protocol ? Has something been done on OSMC to allow the RPi2 USB ports to behave differently than “old” USB 2.0 ports, and more like USB 3.0 ? …or am I completely looking in the wrong direction here ? :wink:

Still learning, but enjoying it !

Remove that ‘linux-firmware’ package first, but beware: you may lose firmware you need for other devices such as WiFi so be careful.

Alternatively, manually extract the files from the Deb package I linked and put them in /lib/firmware. They are speaking about isochronous transfers I think. Not sure how that works on PC

Sam

Thanks @sam_nazarko, will try that tonight.

…could I risk also killing my wired/Ethernet port too ? (in which case I would be stuck)

…and if everything goes down in flames, can I restore previous firmware simply by apt-deb install linux-firmware ?

Again, thanks for your help and dedication.

Have you purchased the codec for watching live tv? mpeg 2

Yup, forgot to mention it :blush:

(Upon initially trying the tuner on the RPi2 sans codec, I still got the sound fine. Adding the codec license also brought the video back to life.)

My problem is that now with the tuner on the Ubuntu backend, all is garbled, including the sound…

So the problem is not on osmc but on ubuntu? I would say you do not have enough bandwith you need a very good network to send from osmc to ubuntu raw data stream.

Try also vlc has the backend receiver.

Hi @taiebot, that is correct. The problem is actually on Ubuntu.

…but since the device works on OSMC+RPi2, I am hoping for some piece of soft/firmware I could copy from one to another to make my Ubuntu backend work :confused:

I had tried dvb-apps tools such as scan and (a)zap on the Ubuntu machine, but even though it did detect the services/muxes, the azap program produced lots of errors when attempting to receive signals.

I still have some suggestions from fellow forum members to try, but your network remark made me wonder, in general terms: What happens when one tries to view a raw TV data stream on a mid/low-bandwidth network (e.g. wireless-G) ? Does the picture simply pixelate or the motion jitter/lags while buffering, or the whole stream becomes entirely unreadable ?

How is the stream on the ubuntu machine. Is it ok or is it garbage as well.

I had lots of drops when i was watching tvheadend streamed from my pi to my tablet through my wifi.
I would recommend a wired network to make sure packets are not dropped.

The stream is also garbage on the Ubuntu machine, as I get lots of “continuity errors” on both the sound and video streams.

I am more and more thinking it might be a hardware issue…