Linux ssh scp logs hell


I’ll admit I am a noob to linux. Though i’ve used it on and off for years, only now with the pi and sshing everywhere am i starting to feel comfortable using it.

Until now that is. i… i just don’t know anymore. It’s like there’s too many problems to even track down. … it works nicely for a short while, then … bad behavior. I’m trying to learn and trouble shoot, but I can’t even read the bleeping logs … idk…

if i am sshed into osmc and i try to use either pico or nano to read the kodi.log file, i get a blank unresponsive terminal window. … maybe error file too big (87mbs??)

I’ve attached a picture of my attempt at scpeeing it to my computer for further analysis. scp fails, though i can happily log into the machine and ssh all over the place. permissions on osmc rpi are very permissive, no sudo required to edit the settings files for instance. i’ve even tried with strict checking off and no hosts file as per google. same error.

What am i doing wrong? Please and thank you. I feel exasparated. maybe rpi isn’t meant to pvr over wifi… maybe i’m asking too much (though 15mbps over wifi shouldnt be too much)

I wouldn’t use pico or nano as a log reader, certainly not for an 87MB log.

I’d use less which is more suited for paging through or searching in large log files, and also has a follow mode.

Howdy folks,

It took a few more reads on stackXchange … it took a few more. deleting hosts doesnt do anything. ubuntu needs a key exchange between both hosts. How do you key xchange then? … ah here’s solution!

  1. on ur ubuntu pc, install openssh,
  2. use command ufw allow 22 (to let unlimited password attempts?)
  3. log into osmc, accept key
  4. from osmc, log back into ubuntu box with ur account name and password, accept key
  5. logout.
  6. harden or close your openssh server lest some rogue hacker sharing the starbucks wifi brute forces ur password

now you’ve traded keys and shouldnt see rejected key error anymore when scpeeing.

take care hope this helps other linuxers out there. thanks for the replies. if this is obvious, remember… noobs roam here…

This has never been necessary in my experience, and never seen it reported as necessary by anyone else on these forums. Overzealous ufw rules for lan maybe?