Lipsync issue

I have a lipsync problem with some files. The playback starts normally, but after a few minutes the lipsync appears very clearly. If I press pause or stop and restart the playback the lipsync is back to normal. If I play the same file via KODI 20.2 on my TV (Sony Oled Google TV) or via PC there is no lypsinc problem. Vero V playing from USB3 (hub) hdd ext4.

Mediainfo :


Thank you in advance

Variable frame rate files tend to be problematic even with older Vero models. You might try rebooting and see if temporarily fixes the issue (I don’t know why this would be but a couple times I’ve had sync issues I hadn’t been able to reproduce after a reboot) or failing that you could try temperedly disabling hardware decoding to see if that deals with it better.

Thank you for your reply
Turning off hardware decoding fixes the lipsync error permanently. Before the first restart, it took about 1.5 minutes for a serious lipsync error to develop, and after the restart, it takes about 5 minutes for it to develop again.

Good to read I am not alone.
I am having this issue with PVR recordings (DVBClient). After a few minutes I have a lip-sync issue. If I press pause the audio stops, video goes one for a shortwhile. If I press play it goes well for a few minutes. This repeats itself continuously. I don’t have this issue while playing 1080p/UHD movies.

It looks like it is getting worse with latest firmware for the Vero V.

This is quite a strange encode. If you plan on watching a lot of these files back to back, I’d suggest disabling hardware acceleration.

I’ll see if I can think of a good approach for deferring clips like this to software decode as standard to save you toggling settings.

If you could share the video with me that would be useful


Can you try copy a recording from DVBclient to local storage and see if you experience the same issue?


I uploaded the file to google drive, should I put the link here or?


Hi, Thank you for the prompt reply. I will do some testing and get back to you.
I have also changed some settings in the audio chain, so let’s hope it is solved already.

I also watched a video yesterday, that started to be in sync and after a few minutes sync was lost.
Mediainfo shows 25.000 fps, technical info on Vero V shows 50 fps. I was not able to fix sync by shifting the audio + or - a little in KODI, it made things even worse, as the video was delayed several seconds then.
It’s a downloaded PAL 1080p web stream, so 25 fps should be correct.
Stopping and restarting the video restores sync, but after some time it was drifting away again.
I did not experience this with any other files I played in the last weeks.

We are looking in to such an issue with 25/50 content. It should also affect Vero 4K.

Set up OSMC V over the holidays and unfortunately we’re are getting major lip sync issues when playing back UK DVB TV recordings (remux’ed into HLS/TS streams). This will be 25fps interlaced video. Drifts over time getting progressively worst.

We also use subtitles. When audio out of sync then hit pause on kodi playback, the audio stop immediately and the video plays on for a few more seconds before pausing.

Think it affects both h.264 and mpeg2 video files.

Tried disabling hardware acceleration for h.264 to see if that fixed it but the video stuttered a lot like the CPU was unable to keep up with playback 1080 h.264 via software.

If you press pause and resume playback after a few seconds, is the lipsync issue fixed? Does skipping fix the issue?

I also have big troubles with lipsync while watching waipu livestreams on my vero v

Yes and yes. But then it starts to drift quite quickly again when resuming playback.

Ok, can you post a debug log? Please also activate component specific logging and select video and A/V timining components. Reboot twice and then reproduce the issue.

How long does it take until you get the lipsync issue? - these are my logs.
For example at 16:40 Vienna-time audio was out of sync on RTL HD (WaipuTV)

Bad luck :frowning: . It seems the kodi log file is corrupt, it’s missing:

====================== Kodi Log =================== HyhIT4UP
An error occurred while grabbing Kodi Log:
 UnicodeDecodeError: 'utf-8' codec can't decode byte 0xfc in position 2401: invalid start byte
---------------------- Kodi Log END --------------- HyhIT4UP

Can you try again? Just reboot and reproduce that issue.

I will do tomorrow

1 Like

same problem with my vero 4k and The Screen freezes for a short time and then continues with lipsync issue.

Tested with a Mibox4s and Kodi 20.2 with no lipsync issues.

Hope it works now: