LIRCd doesn't work after January upgrade

Hi, my remote contorl stop working after upgrade on RPI2.
Tried stop eventclient, lircd and run lircd alone, irw doesn’t show any key press :confused:

As I mentioned we also need logs to help.
Provide URL of grab-logs -A

You won’t see key presses with irw unless you go to the MyOSMC and turn off the ’ enable gpio’

I have this setting off, before update RC work, after upgrade don’t.
Clean install 2015-06 RC works, after upgrade to January stop working.

Are you using an RC6 remote by any chance?

The LIRC configuration you currently have configured is the one for the OSMC IR remote. Unless you are using the official OSMC IR remote, this is wrong.

If you were using an RC6 remote and didn’t configure anything before, then you should select an appropriate RC6 remote configuration in My OSMC. I disabled the kernel’s RC6 decoder by default to prevent duplicate presses when using an LIRC configuration

You can also remove the blacklist file from /etc/modprobe.d, but while this will return kernel based decoding of your remote, we recommend you use LIRC (and My OSMC’s remote option) for finer grained control of your button mapping and better repeat button press handling

Thanks, it is RC6, i changed settings to rc6-mce-lircd.conf and some buttons works now.
Can i use my own .conf ? I can’t start irrecord…

But main problem resolved :slight_smile:

Yes, you will likely need to learn some keys

Try stopping Kodi first