LIRCD Problem since February update

Hello All, I’ve just updated my KODI krypton running on RaspPi to OSMC. I went through My OSMC - Remotes and browsed for my Lircd.conf file I had on my SMB share. When I selected the .conf file nothing happened. No error message. This was puzzling (I had activated GPIO and selected the correct pin) so I FTPed the lircd.conf across to /home/osmc then did a sudo mv to move it to /etc/lirc. When I selected it from the list then it applied the new lircd.conf and my old remote is working fine.

Is this a common or known issue?


Thank you for your reply - I’ve seen your similar post on another thread. When I browse to my home folder I cannot see the .kodi folder only Movies, Pictures, Music & TV Shows folders… Hence why I copied it into /etc/lirc

Click the green title in the link I provided to read the entire context.

I did Andre, when I add /home/osmc as a source in file manager and browse to it in My OSMC > Remotes I am unable to access the folder .kodi
Could this be a permission problem?

Ok, yeah. Just go to Settings>Media>General and enable show hidden files/folders.

Sorry I also didn’t realize that /home/osmc would have to be added in file manager. You could honestly just leave the .conf file in /home/osmc/ and it would be equally safe from update there as well.

Ah ha! Thank you for that Andre. It’s always something simple in the end.