Live tv unwatchable due to buffering

I’m trying to uses an iptv service for live tv on raspberry pi 3b+ with the latest version of osmc. However all 1080p channels and sometimes 720p channels are unusable due to buffering (loading circle) every few seconds. The pi is connected directly to the router via ethernet and shows speeds of around 40mbps (which is the expected speed). I tried the same iptv stream on my pc on the same network and all channels works flawlessly so the issue is with the pi. Usually the 720p channels get if I close it and open it again but this does not work on 1080p channels.

Here are the debug logs.

Any help is much appreciated.

Without reading the logs, is there perhaps a codec issue. I know slot of streaming services has changed to h265 for video, others have changed the audio codec. My older android ceeps buffering since the change of audio codec, so audio is no longer hardware decided.

Not sur about that, there is this part in the the logs tho

: CAESinkALSA::InitializeHW - Your hardware does not support AE_FMT_FLOAT, trying other formats
2022-01-25 00:03:43.013 T:440 INFO : CAESinkALSA::InitializeHW - Using data format AE_FMT_S24NE3
2022-01-25 00:03:43.013 T:440 DEBUG : CAESinkALSA::InitializeHW - Request: periodSize 2205, bufferSize 8820
2022-01-25 00:03:43.015 T:440 DEBUG : CAESinkALSA::InitializeHW - Got: periodSize 2205, bufferSize 8820
2022-01-25 00:03:43.015 T:440 DEBUG : CAESinkALSA::InitializeHW - Setting timeout to 200 ms
2022-01-25 00:03:43.016 T:440 DEBUG : CAESinkALSA::GetChannelLayout - Input Channel Count: 2 Output Channel Count: 2
2022-01-25 00:03:43.016 T:440 DEBUG : CAESinkALSA::GetChannelLayout - Requested Layout: FL, FR
2022-01-25 00:03:43.016 T:440 DEBUG : CAESinkALSA::GetChannelLayout - Got Layout: FL, FR (ALSA: FL FR)
2022-01-25 00:03:43.016 T:440 DEBUG : CActiveAESink::OpenSink - ALSA Initialized:

try this:

Thanks but I think that solution is for drm streams only. Not applicable in this case.

Well there is a setting in iptv-sc to use input stream.adaptive. Doesn’t hurt to try, I’ve never needed it.

I tried with it turned on as well. No difference. From what I can see in the logs it seems to be an audio sync issue.

If the Mrs permits, I’ll try to setup my pi3 and check if I can replicate

Thanks for taking the time.

I found lots of these errors in the logs. Does anything seem off to you?

2022-01-25 00:03:52.420 T:439 DEBUG : ActiveAE::SyncStream - average error of 96.339143, start adjusting
2022-01-25 00:03:52.520 T:439 DEBUG : ActiveAE::SyncStream - average error 0.660173 below threshold of 30.000000
2022-01-25 00:03:53.132 T:988 DEBUG : CDVDClock::SetSpeedAdjust - adjusted:-0.050000
2022-01-25 00:03:54.145 T:984 DEBUG <CWebserver[80]>: request received for /jsonrpc
2022-01-25 00:03:55.808 T:990 INFO : Skipped 3 duplicate messages…
2022-01-25 00:03:55.808 T:990 INFO : CVideoPlayerAudio::Process - stream stalled
2022-01-25 00:03:55.934 T:988 DEBUG : Stream stalled, start buffering. Audio: 0 - Video: 0
2022-01-25 00:03:55.935 T:988 DEBUG : CVideoPlayer::SetCaching - caching state 1
2022-01-25 00:03:55.935 T:988 DEBUG : CDVDClock::SetSpeedAdjust - adjusted:0.000000

Are you running stable or staging? Just reimaged the Pi3B+


Problem replicated, will start investigating. Debug and component log for PVR,Video and Audio enabled.

But as you say, one core is 100% almost all the time, I wonder if the addon could be buildt with multicore/multithreading.

Will get back to you when I got something, but I have to pick up the kids from school now.

1 Like

Don’t think that’s exactly what my problem is. This is what htop shown when playing a 1080p channel with frequent buffering.

I’m using i-key then o-key to see deatils while playing

If you mean this screen it shows the same thing too

True, the more i look at it it looks like it was a fluke, two times in a row, while it was “halted” one core went to 100%, but a few more times it hasn’t so might have been other circumstances.

Well I’ve not had much time to look at this yet, hope fully when the kids goes to bed.

1 Like

Well looking at my logs, I seem to have to find some computer speakers (probably in storage in the basement of the apartment complex) or something, because my log is filled with “Alsa: no active sink”, which probably can contribute to pi3b+ being a little prone to halt playback. Or I’ll wait till tomorrow while the 15 year old is at school and abuse his TV.

In short, just past 10pm here and rummaging in the basement, will probably upset more then one neighbor. So I’ll take a pause for the evening and get back to you when I have some cleaner logs to analyze. Sorry.

1 Like

No worries. Thanks for all you are doing.

Hi, any progress on this?

Due to kids turning their stomachs inside out, the last 36 hours. I’ve had little to no time to even sit down. And I’m still perplexed over what to put in the a/v jack, and if it even give sound in v.19 unedited. Might steal Tims BT/usb/aux-speaker on wheels.

Been awake for 22 h now, cleaning up after a 6 year old(that woke me around 2 am last night, "Dad my tummy is hurting, rumble+gulp. “Run to the bathroom and let it go”) and a 11 year old that seems to have issues aiming. I’m not picky, a bucket, the toilet or even in the sink… All are better then 2 thirds in the bucket, missing our on lifting the seat on the toilette.

Sorry for the visuals, but I can hardly keep my eyes open, felt obligated to reply at least.