LiveTV / VU+ addon with OSMC 2016-01 on RPi2


I just installed OSMC 2016-01 on a RPi2 and did a manual update.
I have the following setup:

  • a (remote) TV receiver which runs an Enigma2-like distribution (exposes the video stream as TS streams to a web interface - OpenWebIf, I’m sure many people are familiar with it)
  • a remote RPi2 which acts as a VPN server
  • a local RPi2 (the one running OSMC), which has the VPN client installed and configured

The problem:

  • playback of HD channels is terrible - stuttering every 2-3 seconds, image gets torn etc - basically unwatchable
  • playback of SD channels is fluid, although the quality isn’t ideal

I tested with the VPN using both UDP and TCP. I tested the VPN throughput with iperf - I get consistently 15 Mbps in TCP mode and ~25 Mbps with 0.02% loss in UDP mode. A HD stream has ~12-~14 Mbps and a SD has 3-8 Mbps (as reported by VLC).

I tried enabling acceleration for both MMAL and OMX player, only for one of them (alternatively), for none - no benefit.
The same streams work fine if I play them back from my desktop PC, which is on the same Internet connection and VPN as the RPi2 with OSMC.

I’m kind of out of ideas and was wondering if anyone has any hints. I’m still wondering if the MPEG2 license will make any difference, particularly for HD channels.

Are the streams MPEG2 encoded? If so the codec licence will make a big difference and would be your only way to reliable play them on the RPi

That’s the strange thing.
The HD streams are H.264/MPEG-4 encoded for video, but the sound for most is MPEG-2. Would that play a part?
I also tested with one stream which had H.264 video and AC3 sound, more or less the same issue.
I guess I’ll get the license and see.

No, audio decoding shouldn’t be the problem and I don’t think the license solves that issue.

Got the MPEG2 license and ran some further tests today - no go.
I even tried OpenELEC - same behaviour, the channels (particularly HD) get cut off, interrupted, image is tearing etc.
I also experimented with various values for the GPU-reserved RAM, no benefit.
Using an Ethernet connection instead of WiFi did not yield any benefit either.

Any other ideas?

To get a better understanding of the problem you are experiencing we need more information from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us.