Lockups with Raspi3

I’m not sure this is an OSMC thing. It may be a Kodi issue, since it happens in LibreElec, as well.

This started happening about 2 weeks ago. After watching a video (from LAN, not fstab mounted) I would often have kodi.bin lock up when I tried to start another video. When this happens, I can SSH to the machine, but nothing I do will clear the lockup, despite having a fully normal SSH session.

Tried ‘sudo service mediacenter restart’, ‘sudo kill -9 kodi.bin’ and even ‘sudo reboot’ The image stays on the screen and I get 1/10 second blips of audio every few seconds.

The ONLY thing that works is a hard reboot by pulling power.

If I preemptively reboot after watching a video, I have no issues.

NOTE: this doesn’t happen every time, but often enough to make the preemptive reboot the preferred action.

I have tried everything I can think of:

Different power supply
different pi
different SD card
different builds of OSMC (including one from May, long before I ever saw this problem)
even tried LibreElec

They all do it.

This is primarily why I’ve ordered a Vero 4K. I’d like to get to the bottom of this. I have a hard time believing that I have 2 RasPi3s with the same hardware failure.

This is why I think it may be a kodi thing.

Any ideas of how I could track down the source of these lockups?

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Have you bought the Raspberry Pi Codecs and installed them?
This enables GPU hardware acceleration , for MPEG files.

If you log into your Pi via SSH monitor resource usage with htop.
You may have to install it first:
sudo apt-get install htop

Start htop first monitor CPU useage then start one of your video files,
Any spikes in useage and you may have to install the codecs.

For Comaparsion on my RPi 2
A 1080p video 1920x1080px @25fps
uses between 2 and 15% on each of the four cores.

You can also use the TV remote control and press return to get onscreen useage stats.
On my system without the codecs, CPU useafe was much higher, between 20 and 50%
on each core.

Failure to obtain and install the codecs should not result in a hard lockup.

I found the problem. I was powering my 1st Gen ChromeCAST from the USB ports on the RPi3. I never got a voltage warning from the pi at all. So, I assumed all was OK.

When I switched the CC to its own power supply, the lockups stopped. I’m not sure if it was a power draw issue or whether there was some sort of attempted communication between the Pi and the CC.

This was the only remaining variable that I hadn’t tried, and I had previously discounted it since I wasn’t getting any indication from the Pi that there was a voltage issue.

And for the record, I do have the codecs – they were installed and running. Not having the codecs installed would result in slow, choppy playback, not a A/V lockup.

It’s strange that it only locked up the video chip… I could SSH into it and everything. I know that the machine was working (mostly) since I installed htop from SSH while the lockup was happening.

I’d be interested to know what caused the problem. I’m glad I found it, but that sure was weird.

It would be power related.

If things come with an independent PSU, you should use them.

The Gen1 Chromecast didn’t. It runs on VERY low power.

Interestingly, I plugged a 64GB USB3 stick into the RasPi3 today…and it locked up again.

So, there’s definitely something up with USB power, and a single USB flash drive should definitely not do that.

You may want to check your power supply or get a powered hub. But a good Pi power supply will be able to power a USB thumb drive without external power!

I have 2 PSUs that I bought from MCM Electronics when I bought the Pis from them. I bought them about a year apart, too, so it’s unlikely that it was a “bad batch” of PSUs. They claim 2.5A output, and Both of them produce the same results on 2 different Pis. I don’t have any more high power PSUs.

If a Pi3 can power an external 2.5" hard disk (with a good PSU), there’s no reason that it shouldn’t be able to power a Gen1 ChromeCast.

If the Vero 4k (when it gets here, lol…it’s just now gotten into the USA) uses USB Mini for its power, I may try that PSU, as well. Just for more data.

V4k uses a barrel type connector.

Vero 4K uses a barrel jack.

You only ordered a couple of days ago – you’ve been spoiled by Amazon Prime :wink:

Use the USPS website for tracking (it’s better).

This articles says that the Chromecase uses about 420mA under peak load, which could be higher than some external USB drives.

Actually, I don’t use AzPrime. I’m just impatient to play with the new toy, lol.

It’s probably best that the Vero uses a barrel connector. I find that USB power is finicky at best.

Ah well. Maybe I’ll spring for another higher-power PSU.

There is a high quality model available on the OSMC store.

I’m sure that I can find one here in the US that’s just as good. I would expect that the ones I get from MCM are good…but that’s what I have. So, if I decide to get another one, maybe I’ll check AdaFruit, since they are US-based and I can probably get a good one from them a little faster and/or cheaper.

Once the Vero gets here (Yes, I am impatient, lol) It will likely be less of an issue, since the Pi will be retasked to be an OSMC box in the bedroom, and that machine won’t get nearly as much action as our main device in the living room area.