Log access

Hi I’m relatively new to the Raspberry. I have a Pi3. After setup the other night, I was able to get to the app store. It was late so I didn’t download anything. Today however I can’t even access the app store. I’ve gone into all the settings and found that I’m not connected. I’ve already gone through every network setting and verified all settings are correct and I have connectivity. I’m currently in a Putty window and am able to ping webpages from the Pi. So now I’m really stumped! I tried to pull the logs, to find out what’s going on, but all it will do is save to the SD card. How do I access those logs without powering down and pulling the card? I can but this seems a bit tedious given it’s just information. Is there a way to read these internally or through SSH? Help! I’m going crazy!

Also thanks!

If you can login via SSH, it sounds like you do have network connectivity.
You may have some DNS resolution issue however; try pinging google.com

I did and it came back connected. That’s what’s confusing. I also changed my DNS to Google’s, to no avail.

osmc@Tygra:~/.kodi$ ping www.google.com
PING www.google.com (74.125.21.106): 56 data bytes
64 bytes from 74.125.21.106: seq=0 ttl=45 time=8.401 ms
64 bytes from 74.125.21.106: seq=1 ttl=45 time=8.424 ms
64 bytes from 74.125.21.106: seq=2 ttl=45 time=8.593 ms
64 bytes from 74.125.21.106: seq=3 ttl=45 time=8.671 ms
64 bytes from 74.125.21.106: seq=4 ttl=45 time=8.609 ms
64 bytes from 74.125.21.106: seq=5 ttl=45 time=8.402 ms
64 bytes from 74.125.21.106: seq=6 ttl=45 time=8.433 ms
64 bytes from 74.125.21.106: seq=7 ttl=45 time=8.425 ms
64 bytes from 74.125.21.106: seq=8 ttl=45 time=8.501 ms
64 bytes from 74.125.21.106: seq=9 ttl=45 time=8.316 ms

Upload logs via the command line, with Kodi debugging enabled, after producing this problem.
Also reboot first.

Do you know the command line for that?

Also I’ve rebooted about 5 times now.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Ok. Working on that now. Thanks! I thought I’d selected the Enable Kodi logging, but had deselected. Rebooting now.

Ok posted the log to the requested location, in the post. Do they respond in said page or somewhere else? The link didn’t say one way or another.

You should post the link here. :wink:

Ah ok.

http://paste.osmc.io/titewibiyi.vhdl

Hi,

That isn’t a log, either upload logs via myosmc or issue:

grab-logs -A

via ssh/ the commandline and post the url provided.

Thanks

Try this one.

https://paste.osmc.tv/acefofefax

Hi,

It looks you have a noob configuration, which seems to be underclocking the pi3:

# NOOBS Auto-generated Settings:
arm_freq=850
core_freq=375

Are you using the pi3 for anything other than osmc, if not I would reinstall using the installer provided by osmc:

https://osmc.tv/download/

If you require noobs, because you are using other operating systems I would edit config.txt (located /boot)

and remove:

arm_freq=850
core_freq=375

And restart the pi.

Thanks Tom.

Currently I’m only going to use it with osmc and a couple other addons, all related to the media server and streaming. I only ran the Noobs as it came with the Pi and that was the setup. Which is better, modify the code or uninstall and reinstall with the proper download? I’m not hugely proficient in Linux but feel fairly comfortable with subtle manipulations.

Well currently starting with the modification.

Pure OSMC install would be preferable and optimal.

1 Like