Log uploader returns invalid url

  • In Settings > System, select Enable debug logging. (All other logging settings left as default.)
  • Reboot System (Raspberry Pi3).
  • Collect some log data by navigatiing menus and viewing media for a few minutes.
  • In My OSMC Addon > Log Uploader, select Kodi Log.
  • Select Upload Selected Logs Now.
  • The following invalid url is returned:
  • Note, if no log is selected in My OSMC Addon > Log Uploader, a valid url is returned, however it only contains a date/time header and is otherwise empty.
  • The log file, that I manually copied into pastebin is here: http://paste.osmc.io/uwehilupof.vhdl

Screenshot below:

Are you behind a proxy or VPN?
Seems to be working as expected here using paste-log.

I’m admittedly on a Vero 4K but it worked as expected for me on both the Estuary and OSMC skins.

No I’m not.
Nothing interesting in the logs? I have another system setup the same that I’ll check. Thanks for your quick reply.

What happens if you run grab-logs -A also invalid URL?

> osmc@osmc:~$ grab-logs -A
> Logs successfully uploaded.
> Logs available at https://paste.osmc.tv/<html>

Try individual files like grab-logs -X grab-logs -J

Before I saw your reply, I checked my other installation and it uploaded logs with a properly formatted url, as expected. I then rebooted the system with the invalid URLs and repeated the process as described above. It is now behaving as expected, with proper URLs. Rebooting resolved whatever was causing the issue. I’ll mark as solved but not sure why.