Long pause before videos start to play

Looks like you have LAN and Wifi up at the same time that could lead to issues

eth0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC>  mtu 1500
        inet 192.168.2.31


wlan0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC>  mtu 1500
        inet 192.168.2.8
1 Like

Thought I had deactivated wlan0 when I tried to test on eth0 only to see if wifi was the culprit…

Anyways… pi2 and pi3 are doing better… and all I did was…

  • Change nfs from v3 to v4… (After adding Domain to /etc/idmap.conf to get nfs4 to worl properly) for both
  • Rebooted the wireless repeater (re450 running openwrt) the pi2 is connected to. My android phone had no connectivity issues with it, but given network issues was the main culprit you had in mind…
  • Deactived interal wifi and put an external usb 5Ghz-ac wifi dongle (with better reception due to 5dBi antenna) on the pi3 (had been on its internal 2.4 Ghz wifi which I suspect “has aged”…) iperf3 shows wifi speeds went from 10Mbits/s to 98 Mbits/s maybe that helped…

So its possible that :

  • nfs v3 was not an issue (but I’ll stay on v4 now…)
  • internal wifi on the pi3 was/is dying
  • repeater just needed a reboot for the pi2 (never had that issue in the over 3 years this setup has been working)

Thanks for guiding me in the right direction…

It’s good that #dwardor got a solution after hijacking my post, but could someone have a look at my issue? Thanks!

Can you name the movie you played for your logs which has shown the delay?
Also looks like you have sources defined via Kodi NFS access and kernel mounts. I suggest you migrate all sources to the kernel mounts.

One was “Weiner,” the other “Batman Forever” while the debug logging was on.

I find the delay is on all video files.

I’ll have a look at the NFS settings. I recently edited the fstab file for the kernel mounts after reading a wiki entry about it. I thought I’d got rid of the kodi ones. I’ll check this evening.

I have the same setup on both Veros. Only one has this issue.

For the Weiner movie clearly it was still be played via the Kodi NFS access. This seems to be a similar issue we have seen before.

For the time being I suggest you try to change all your sources to just use the fstab entries and rescan your library. Until we might find a solution for the original issues.

2021-09-04 14:56:00.150 T:2607    DEBUG <general>: CPlayerCoreFactory::GetPlayers(nfs://192.168.1.203/data/videos/Movies/Weiner (2016)/weiner.mkv)

Thanks #fzinken. I’ll check and let you know.

Hello @fzinken, you were correct, the mounts were kodi and not through fstab. (Brain fade). i’ve fixed this but the delay persists.

I’ve created new logs: https://paste.osmc.tv/usuvecosof

Logged video: A Beautiful Mind. Please let me know if I can help with diagnosing what’s going on.

Good then we can exclude that as a possible issue.

Ok, was a bit harder to read the log this time as your library was rescanned filling quite some lines. But it seems we are still back to this strange error

2021-09-08 20:49:24.694 T:2607    ERROR <general>: GetDirectory - Unhandled exception
2021-09-08 20:49:24.694 T:2607    ERROR <general>: GetDirectory - Error getting /home/osmc/.kodi/temp/
2021-09-08 20:49:24.694 T:2607    ERROR <general>: GetDirectory - Error getting special://temp/

I still don’t have any explanation for this issue.

My next suggestion would be to try with a reset of the Kodi configuration and maybe just copying your sources.xml from the old config to the new config to just test if it works with a clean config you could then try to copy more back afterwards.

Let’s test with Kodi default settings. Enter the following commands with an SSH connection.

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bak
systemctl start mediacenter

If needed you can restore:

systemctl stop mediacenter
mv ~/.kodi ~/kodi.bk2
mv ~/kodi.bak ~/.kodi
systemctl start mediacenter

If your original setup was restored as expected and you want get rid of the unneeded clean install you can delete that with the following command.

rm -r ~/kodi.bk2

I don’t know if this helps work out what is going on but I have the same issue playing .TS files on a TrueNAS SMB share. The audio seems to play from the start but video starts later. Not sure if it is the same issue but it only started to happen after the last update.

Sounds different, check if you also have GetDirectory - Unhandled exception in your Kodi.log. If yes same issue, if not then suggest to open a new thread with debug enabled logs.

This is the same issue I complained of a few weeks back and not received much support on: Slow video start up - #17 by pinn73

Sorry it’s not. Or do you have GetDirectory - Unhandled exception in your logs.

In answer to your question, I am unaware as a clear response was not provided on the issue. However, the OP’s issue is the same, which was my point.

Hello again @fzinken

Took your advice, moved the kodi config file, copied the sources.xml file and, lo and behold, the problem’s gone. I then copied everything across, the device is set up as before and the videos start instantly.

The thing is, the .kodi directory I moved was huge, in the order of 6Gb. The temp folder was full of very large backup files. I have the known issue of backups not working with an error message. Could this be related? Perhaps the partition is filling up due to this issue and was running our of space? The answer is way above my pay grade.

So, the issue is closed for me for now. Thanks again for your assistance.

Could be, for the backup I would wait till the next update which should fix that.

But I really wonder what the actually problem is/was. How did you in the end restored your Kodi settings. Did you copied back the whole folder?

I just checked your old logs you still had 4.5G free so that was not the issue

/dev/vero-nand/root   14G  8.7G  4.5G  66% /

I copied the contents of the subordinate folders over one at a time. When I copied the temp folder contents, it failed as the partition was 100%. i deleted the huge backup files to make space.

After I’d copied everything across there was only about 600MB of partition space. When I deleted the moved kodi folder and subordinates, there was 9.3GB of space. Maybe I did something strange when copying things across.

There was lots in the temp folder.

Bottom line is it works now.

Thanks, when I see someone else with this problem I might just ask them to delete the temp folder.

Right. This has fixed my issue , too, so guess it was the same. There wasn’t a lot in the temp folder apart from a 6gb osmc backup. Oh ,well, just happy it works.