Looking for Older versions of OSMC \ Random Wifi drop

When I first built my Rpi2, Kodi ran on Osmc
which worked perfectly for a month but after updating, the wifi started
disconnecting randomly. I have tried a fresh install from scratch both
with and without updates but still the wifi was dropping off. In
desperation, I installed Openelec but still the wifi keeps
disconnecting. It doesn’t matter if I am streaming a video on Kodi
(14.2) or just idling, the wifi drops randomly. At current the wifi
strength reports 60-65%.

What I want to do now is go back to the OSMC version that was available on July 14, 2015. Where can I find older versions of OSMC? Thanks.

Have you checked here :
https://osmc.tv/download/images/

Raspberry Pi 2
Release Checksum (MD5)
2015.07-1 d28704569f64902b5fe6ea0272a3d874
2015.06-1 0f95e83ab81e9419166206e5e3bba1dc

or for further back: http://46.37.189.135/osmc/download/installers/diskimages/

ps: i was having the same problem as you are from June and August updates. But it stopped with Septembers’ update. Maybe do a fresh install with that 1st?

What makes you think this is a software issue ?

You say that after updates you started getting wifi drops (updating from what version to what version though ?) but that could be a co-incidence.

You then say that re-installing the previous version that you were on before did not fix your wifi drops. Further you say that you have the exact same issue installing OpenElec, which is a completely different operating system.

It’s very clear from what you say that your wifi problem is not software update related - something in your wifi environment has changed that is causing your issue, so I don’t see what point there is going back to an older version a second time.

Wifi connectivity problems are a common problem in general with all wifi devices, with a multitude of possible causes including interference from neighbouring access points on the same or similar channels, interference from non-wifi devices, insufficient signal strength and so on.

You need to troubleshoot your wifi environment to find out what the issue is here.

Thanks so much. I had been looking everywhere for that.

I will give it a go with the Sept. release. Since you were having the same problem, maybe you also had a another problem that plagued my OSMC experience. I could never properly update my osmc. Every time I did a manual update through ethernet, (auto update disabled) osmc behaved oddly. Update download would end before all the updates were downloaded. I would have to hit update three time before all the updates were downloaded. Moreover, I’d always get an “update error” during download. One time after updating, the boot and shutdown sequence changed. There were dozens of lines of messages all starting with “OK”. Another time after updating, the lines of messages were gone but I got a script error for “My OSMC” so I couldn’t even go into it to change and configure settings. If either the Jul or Sept release resolved the wifi drop issue, I would not update osmc anymore because it just wreaks havoc. However, I don’t like the idea of of keeping up with updates. Have you got any insights into this?

The problem started when I updated from the July 2015 release to the Aug. release. The wifi drop started the very day of the the update whereas before I had never had a single incidence of wifi drop, too much of an coincidence.

When I did a reinstall, I actually did not go back to an old release as I couldn’t find it. Since Noobs, auto downloads the most recent version, it was just a reinstall of August release. Problem persisted with or without updates after reinstalling. I was told on Openelec forum that both Openelec and OSMC share similar kernels and driver changes hence the same problem. The wifi environment within my house has not changed.

My plan of action now is to reinstall the July release or maybe even try Raspbian before eliminating the software theory.

July and August was a living hell for me…The late june update messed up my setup twice…The first time it turned the whole system into read-only…after i reinstalled i was getting wifi drops 24/7, my router’s password was not getting recognized and i had to re-enter it 3 times…in the end when it got connected kodi would crash with a sad face and restart the service.
I also went back to june’s update for a while, then at the end of August i was ‘suggested’ to try again with the august update. Same things…the wifi would drop for no reason, and of course…it was suggested again that its a hardware fault…that my wifi stick had a problem or that my psu was broken or not giving enough juice. The wifi stick worked fine with other distros (openelec, xbian) and the power supply was giving the appropriate amount of power. (I measured the gpio and it was giving 5.12v)…(because osmc goes into turbo mode, there might be a problem with 1-2A psus, but that wasnt my case).
I was ‘that’ close to reinstall xbian again and be done with it…till the Septembers’ update…I didnt see any differences in the github that should fix my problems but for some reason, everything was working fine, just like the pre-june update.
I got 1 crash only since then, the wifi works flawlessly 99% of the time and finally i was able to install ddclient, lighttpd, vnc, samba (although that installed failed…had to do it manually) without a problem.
Thats why i’m saying give Sept. update a try.

ps: there is no Raspbian for pi2…wish there was…its been discontinued and gave birth to osmc. The only similar OS is xbian.

ps2: between june-august i must have installed osmc at least 8 times…the last 2 was fresh install…re-added all the plugins manually…didnt keep anything from before. Didnt even copy my previous plugin settings.

ps3: The first update that messed up my pi2, was a manual update.

Buzzzz! Threadjack

I’d like to know:

  • WiFi dongle used
  • Logs

Sam

1 Like

I am going on my 3rd fresh reinstall. After a month of flawless operation, I’m at wits end and hating every minute of my Rpi experience.

On 2nd thought, I will install the tried and true Jul release instead since I won’t be updating (until I find out why it messes everything up).

Are you sure about Raspbian being incompatible with Rpi2? I couldn’t find any info to back that up.

I’m using the CanaKit WiFi Adapter / Dongle (Ralink RT5370 chipset).

I was told debug log is useless for troubleshooting wifi but here it is anyways: http://xbmclogs.com/p6mskvpes

Be forewarned, it’s long.

A Kodi debug log isn’t very useful for wifi troubleshooting, no. What you need to provide is the system journal, taken after trying to connect to wifi:

sudo journalctl | paste-log

So sorry, i meant Raspbmc.

Sorry for my ignorance but how do you enable/retreive the system journal? Also, I have seen commands like what you wrote highlighted in blue but I have no idea where to input those commands. I have often see the word “sudo” but again I have no idea what it means. I feel pretty stupid when I browse through different Rpi forums cuz they assume members have some functional knowledge of Rpi language but I have next to zero.

You will have to enter that commands on the command line interface of your device. As OSMC currently is not providing a terminal (to be displayed on the screen instead of Kodi) you would need to SSH into your device. If you don’t know SSH it might be quite a journey but basic steps:

  1. On your PC install a SSH client (e.g. putty)
  2. Open a ssh session to your device therefore you should find the IP address of the device (under MyOSMC)
  3. Login with osmc/osmc

Then you should be provided with a command line where you can run all kind of commands e.g. sudo journalctl | paste-log

Hey fzinken, Thanks for the heads up. I tried searching for a tutorial on where/how to input those commands but found nothing. I never would’ve thought it was that complicated. How is anyone suppose to know all this stuff??? I didn’t even know what SSH was. Thanks for pointing me in the right direction. I’ve been avoiding getting into it but now I want to mirror my pc to my Rpi so I will give it a go.

Btw, there really should be a tutorial on all of this.