Loosing WIFI connection (overheating?)


I have a Raspberry Pi 1 B+ powered by a 2000mA supply obtained from ThePiHut.
It uses a WiFi dongle to connect to my local network.
OSMC version: VERSION_ID=“2015.07-1”
XBMC version:
18:17:15 18.896797 T:3023974960 NOTICE: Starting Kodi (15.1-RC1 Git:Unknown). Platform: Linux ARM 32-bit
18:17:15 18.896984 T:3023974960 NOTICE: Using Release Kodi x32 build (version for Raspberry Pi)

Since the last couple of weeks I encounter the problem that OSMC will stop responding to the network. I can’t ping the Pi and movies can’t be played.
When I pull out the WIFI dongle it is extremely hot. If I put it back immediately the network connection does NOT get restored, however, if I wait a bit and then push it back in, the network connection comes back to life and I can ping the device and it’ll work again for a couple of hours.

$ iwconfig wlan0
wlan0     IEEE 802.11bgn  ESSID:"pi3.1415926"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:2.412 GHz  Access Point: B0:C2:87:79:B0:42
          Bit Rate:72.2 Mb/s   Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=100/100  Signal level=86/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

$ ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:87:c3:00:61:9f
          inet addr:  Bcast:  Mask:
          RX packets:4781 errors:0 dropped:105 overruns:0 frame:0
          TX packets:4945 errors:0 dropped:2 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1202575 (1.1 MiB)  TX bytes:1307008 (1.2 MiB)

Lastest log: http://paste.osmc.io/oxobiqicoc

My first thought is that the WIFI dongle overheats.
Would love to hear any suggestions to resolve this issue. Please let me know what additional information you need.

I’ve found the cause of the problem, which was a misconfigured DHCP/DNS server on the LAN.
Changing its local= and domain= settings fixed it!