Losing settings when rebooting Vero 4k (and Vero 2)

This problem seems not solved for me. (Vero 4K latest 17.1 update)

i still get this issue after a view reboots.

All settings are default, skin, language etc…

i enabled debug log now and if i get this again i will post the logs if needed.

17.1 is not the latest.

@Painkiller88

Hello,

are you sure you have the Release 2017.03-1 installed ?

Regard.

yes i have this release.

That’s not a helpful answer. Then what is the latest?

I wrote the latest 17.1 update and 17.1RC2 is the latest…

but on all other plattforms it is the 17.1 final

i think you know what i mean.

Release 2017.03-1 comes in two versions: 17.1-RC2 and 17.1. The correct (17.1) version was release by Sam on 22 March.

If your Kodi log says you still have 17.1-RC2, you need to upgrade to 17.1.

See Kodi Version Query for further details.

1 Like

ah yeah right, latest update over night changed this to 17.1

This is the actual version i am running but the problem is still there after a view reboots skin and settings are default.

Well at least we know you’re now on the latest-latest version. :wink:

Well, the question always is what people are referring to…

17.1 is the latest Kodi version, while the latest osmc version is 2017-3.

But if it was OSMC release 2017-1 that would not be the latest version.

Can you post here which skin you are using and a full debug log which shows you changing a setting, rebooting and that setting not being the same after the reboot?

I simply pointed out that saying “17.1 is not the latest” is not a helpful answer. AFAICT, 17.1 is the latest (Kodi) version.

In post #16 I referred to another thread in which the confusion between OSMC and Kodi versions was resolved. As I also explained in post #16 “Release 2017.03-1 comes in two versions: 17.1-RC2 and 17.1”.

Perhaps it might have been wiser for the OSMC version to have been incremented to 2017.03-2 with Kodi 17.1 but that’s not how it was released.

I am using Aeon MQ7 Skin.

here is the log with debug logs enabled:

http://paste.osmc.io/gevarekeni

thanks

Do you get the same behaviour in the OSMC skin or Estuary?

The pre-reboot kodi log doesn’t show any debug entries, indicating that you didn’t have debug logging enabled before you rebooted. You need to:

  • Reboot
  • Enable Debug Logging
  • Make the change
  • Reboot
  • Check if the setting has changed
  • Upload the logs

Then tell us the new log URL and the setting you changed which reverted.

Ah again, bug just happened :disappointed_relieved:

With last version, release 2017.03-1.

So it is not fixed…!!!

Indeed.

I am starting to think this is a Kodi bug now, as we have all but reverted OSMC specific changes and this is affecting other platforms such as Pi.

If someone can give me an easy way to replicate these problems; I’ve fixed the easiest ones, I’ll look in to this and put it right.

Sam

the easiest way to replicate the issue is simply change your skin to another than the original, than do a view reboots and after a view reboots your settings will be deleted (skin, language, all is default again)

I hope this is the same issue. I could replicate this two times:

  • Fresh OSMC installation on RP3
  • Choose Classic Skin instead of OSMC in the initial setup wizard
  • Kodi starts with the classic skin
  • Reboot
  • Kodi starts with OSMC skin

Thanks – that is great. I will try it tomorrow on a Pi. I know this is a Vero 4K topic but believe it affects all platforms.

Sam