Loss/low volume after most recent update :(

Last time the update crashed my system (RPI 3/OSMC)…this time it’s a little less catastrophic :wink:

The volume was just fine until after I updated to the latest OSMC a couple of days ago (Thanks for your continued great work and commitment, folks!!!) and then the volume went very low on both movies/videos and music. At 1st I thought it was completely gone but after messing with the receiver volume(s) I realized it was just greatly reduced. No h/w changes, only the software update. I’m connected thru HDMI on my receiver. Everything else thru the receiver is normal volume/unchanged.

Anything I should be looking at on the RPI 3/OSMC? Or should I just do a reinstall of the update?

I found postings from the past where some people have experienced some kind of volume loss, but it wasn’t clear it was related to my situation.

Also, I noticed that there is a volume control step setting in System/Settings but no obvious way to change volume in OSMC. Maybe that has nothing to do with audio over HDMI since it’s digital.

BTW - Other than the most recent 2 updates, OSMC has been working pretty flawlessly. I appreciate all the painstaking effort people are putting into it.

Thx in advance and cheers…

No one else seems to have reported this. Are you playing the same files you were before?

Please post debug logs, a screenshot of your audio settings and your audio setup.

There haven’t been any changes to audio on Pi outside of DACs in the last two years.

Thx for the fast response Sam.

Same files, mix of FLAC and MP3 (and some WMA). Movies also a mix. Same problem on audio whether movies or music.

I’ll have to figure out where the log files are and get them off the system (easier on Windows than RPI 3/OSMC). Were there specific logs you need to see…or are there just the general boot stuff I see at a reboot/powerup? Audio settings…I assume from the System Settings screen. Audio setup…from same place? Or do you want to know the physical setup/connections?


For the

You are joking of course. Just use the log uploader in MyOSMC or grab-logs -A from the commandline.


Here’s the link for the log files: https://paste.osmc.tv/ovanexijuk

Now to work on the screenshots :slight_smile:


Actually, I wasn’t smiling since I hadn’t done it before. Thx. That was easy.

Glad you figured it. I wouldn’t know where to find Windoze logs.

More usefully,

F9/F10 from a keyboard, or press OK when playing something then navigate to the loudspeaker icon and select that to get to audio settings.

I can navigate Windows much better than Debian/OSMC.

F9/F10? Not sure how that applies to a “headless” RPI 3/OSMC setup…or am I missing something obvious? I do comm with the HTPC over ssh thru a Win 10 system, but not sure if that’s what you’re referring to.

So, since you’ve stepped into this thread :slight_smile: I have (some of?) the .png screenshots. How do I get them to Sam?


I have a couple of .png files for the audio settings. Not sure what you mean by the “audio setup”?

And best way to get the .png files to you?

Thx and cheers…

If you are using the Kore built-in webapp, there is a volume control in it. Otherwise, I don’t understand how you are controlling the Pi or watching movies, if it’s headless.

Just drag and drop them here in a post.

1 other item of note I just remembered: Before this problem appeared (i.e. before the update) when I switched from my satellite receiver (no, I haven’t quite yet cut the cord :frowning: to the RPI 3/OSMC input, I had to lower the volume ~10 steps cuz the RPI 3… was much louder.

Quick update with a couple of other notes: I checked my receiver to see if somehow something had changed for the RPI 3/OSMC HDMI input (Specifically, Intellivolume on an Onkyo receiver). Nothing of note. Other thing I noticed is that the feedback/response sounds (like when pressing a remote button…and also during a reboot there is usually a noticeable “chirp” sound a few times along the way) are also very reduced, so this seems like something specifically related to the OSMC/RPI system.

Sorry…maybe headless was the wrong term. I’m using strictly a remote (from my receiver). Like I said I can ssh into, and if I’m really in a bind, I have the USB ports accessible so I can plug in a keyboard/mouse.

I just noticed something else. I realized that I’ve been messing with the system so my logs weren’t really “pristine”, so to speak. I just did a reboot (from OSMC) and it went thru the typical boot up text, got the “M-blue” screen (prior to Confluence showing up), then into a dark screen. So, maybe this is worse than last time in some ways :frowning:

I had this happen earlier today and had to do a hard reset. I just tried to ssh over to the system and it refused the connection. Had to do another hard reset to get it up. New log files: http://paste.osmc.io/fayapaboke.vhdl (these have been “cleaned”)

.png files…drag and drop didn’t work :frowning: …nevermind…sometimes I just feel so dumb :frowning:

I solved the problem, purely by accident. Turns out I had installed the Kodi Remote (both the “Official Kodi Remote” app and non-official one) onto my cell iphone. Under what looks like a “Settings” button, there is a volume control (in both remote apps). It was set to ~1/4 volume. Once I moved it to full, everything was back to normal.

So a volume control function does exist in OSMC for the RPI (just not obvious it does, if it’s even accessible :frowning: I pretty much went thru the “Settings” in OSMC and saw no volume control button at all…unless it’s in a place I wouldn’t have thought to look. You might want to consider this and ensure the “Settings” capabilities in OSMC more consistently match the remote capabilities, especially the Official Remote. It’ll prevent people like me from taking up yo valuable time in the forum.

Thx for the help anyways. I appreciate it. Just glad I figured it out.

I think you get this wrong! Volume is not under settings but it is a central part of Kodi.
On a “normal” remote connected to Kodi/OSMC you presss +/- to change the volume and as soon as you do that you will get the volume setting on screen.

You’re right, my bad. After I wrote my last msg it came to me that the reason I never saw a volume function is because the remote I’ve been using wasn’t set up to support it. So, I never knew that existed. I am humbled by my own blindness :frowning: However, I’m surprised no one mentioned that to me thru all of this… :wink:

Again, thx and cheers…

Well well well


i had the same problem following the last software update.

after reading this thread, i realized that my samsung remote had been somehow deconfigured, and the pi’s volume lowered to less than 1/4. (i had to crank the tv set’s volume to 100, max, to be almost loud enough.)

it wasn’t obvious, but i had to configure the remote under osmc’s “remotes” tab first, because it was working only as a “generic”, which didn’t give me the right keys to access the player controls.

after fixing that, once a video was playing, pressing “enter”, at the centre of the arrow keys, opened a control panel with timeline, playback controls, and a volume control, for the player. that’s the one that needs to be set higher. (it’s easier to leave it at max, and control the sound from the tv’s volume.)

i hope this will help other people who are in the same boat.