Lost access to my Google Authenticator app - what to do?


I have lost access to my Google Authenticator app - and don’t see any opportunities to reset it

How do I reset it - to get back into my account?

Do you still have access to your google account?

Yes I do!

What error is GA giving you?

No errors - I did a factory reset of my phone - and forgot all about backing up GA.

I’m not an expert on it but I think unless you exported the codes beforehand you can’t get them back and you’ll have to set up the codes again.

Others might know more.

I agree!

I need to disable 2FA on my current account - and then enable it again.
To disable it - I need to login - and are prompted for 2FA code…

Catch 22…

Did you create and store backup codes when you set GA up? Explained more below.

Unfortunately no!

Can you do this bit from the article?

'If you missed that step during the installation, you can get those backup codes anyway. For that, you have to go into your Google account and then follow these steps:

  • Click on “Security” in the left-hand column.
  • Scroll down to and select “2-Step Verification.” You’ll probably have to enter your password.
  • Scroll down to “Backup Codes” and click on “Show Codes.”

Yes I have access to backup codes!
Won’t help med logging into my Vero account.

But can the codes be used to gain access to GA on your phone?

I already have access to GA on my phone
GA is not the issue - logging into my Vero account is the issue - 2FA required.

How can I generate new codes - when I wiped my phone.

Not possible.

Then is it giving you the 2fa for this site? If not them I’m sure @sam_nazarko can help.


Yup - that’s what I figure too.

You can use the recovery code which would have been generated to login at any time. You can then reset the code.

I tried the backup codes I found when I logged into my Google account - no dice!

Unless you are referring to something else Sam?

I even tried to reset my password for my OSMC account - and entered a random One Time Password - hoping that I would get a link to reset my authenticator app - but no.

I have disabled two factor authentication on your account.
You should now be able to log in again.

Thank you very much Sam!

I have now done this:

  • re-enabled two factor authentication
  • chosen another authenticator app - with backup.
  • made a backup of recovery codes - just in case!

Thank you very much.

As always great support!

1 Like