Lost audio on upgrade to v19

After the upgrade to Kodi v19 there is no sound coming from my receiver (Denon X2200W, connected by HDMI).

When does it occur:
Always, there’s no specific condition or steps to reproduce.


OSMC remote dongle and external bluray drive (external usb power).


Helpful troubleshooting information:
To troubleshoot I have already tried the following:

sudo apt-get update
sudo apt-get dist-upgrade
sudo reboot

And to rule out any userdata/addon problems I have (hopefully) temporarily switched to a fresh setup using:

sudo systemctl stop mediacenter
mv ~/.kodi ~/.kodi-backup
sudo systemctl start mediacenter

In the past I have manually executed commands (install some packages if I remember correctly), to enable the device to function as Bluetooth speaker. Considering there is a new Bluetooth stack, my hunch is that I need to uninstall some of the old stuff that’s interfering. Any advice in that direction would be appreciated.

P.S. some small notes:

  • The clean profile by default selected the 1920x1080i resolution which added some blurring effect to menu items in the (default) skin. Selecting the progressive variant manually solved this, but more accurate detection might help others.
  • The support request guide has a link to a old pastebin url (http://paste.osmc.io/) under the “Sanitizing your logs” section.
  • I’ve seen a bunch of sad faces while navigating Kodi using my regular userdata folder, but if they persist after fixing the audio I’ll create a separate topic.

P.S.S. import note:
Thanks a bunch to the whole OSMC team for the huge amount of time and effort spent on this release! Looking forward to enjoy all the new features and bits coming with it! :clap: :partying_face:

You have pulseaudio installed, need to remove that.
See this comment

See [How-to] install bluez-alsa for Bluetooth audio

Known issue - we are looking into that - possibly only happens when an AVR is connected but TV not switched on.

Thanks a bunch @grahamh and @fzinken you guys are quick as lightning! Issue solved, audio is back! :partying_face:
Switched back to my regular user-data and seen another consistent crash at the PVR radio section though…next topic is incoming. :slightly_frowning_face: