Lost CEC-HDMI after updating to RC3

hi, just updated my RPi2 and… lost my remote… i can connect via LG SimpLink (got the green checkmark) but that’s it. OSMC doesn’t respond to any command from remote…

what can i do?

i guess something has changes in the CEC library?

because in RC2 the arrows from remote were working, now only button BACK works.

PLEASE bring back the old stuff!

We have not changed the CEC library at all for this release.


Try resetting your TV.

Shut down your Pi and turn off the TV then unplug the power cord for the TV for at least 30 seconds. Then plug the TV back in again and turn it on, finally turn your Pi on. See if that helps.

1 Like

CEC working ok here (samsung)

ok, so nothing was helping i’ve connected a usb mouse, enabled debugging (some PITA to navigate using a mouse), ssh-ed to osmc, run the
tail -f .kodi/temp/kodi.log |grep OnKey:
command, and after several clicks of the usual buttons on the remote ALL is working as it should.

VERY strange.

Perhaps it isn’t the CEC at all. I had the same sequence when I updated an RPi 2 earlier today. First my remote (not CEC) wasn’t working (keyboard and mouse were). I then attempted to check the remote, which ended with swapping to an RPi 1B+ (after not getting any OnKey signals) - it worked, so I swapped back, and everything worked again!
Since the failure wasn’t repeated, I couldn’t get good info on it.

so then it is a OSMC related bug?

I’m having same problem. It seems that OSMC is receiving my buttonclicks (look below) but i don’t get an “OnKey”.

12:48:40 T:1863316512 DEBUG: PushCecKeypress - received key a7 duration 0
12:48:40 T:1863316512 DEBUG: PushCecKeypress - received key a7 duration 264

What am I missing? This has worked flawlessly for me before. I have tried resetting the receiver (which is my CEC device) without any result.

Same problem here. I updated my rpi2 and after that Yamaha receiver rx-v373 cec is lost. I try to reset receiver and RPI many times but nothing happens.
Any ideas?


okay, so after last update - i’ve lost half on my buttons!!!
so i have stop, play, skip, but no left, right, up and down…

how can i downgrade the CEC-HDMI?..

We haven’t made any changes to the CEC library in recent updates


but it stopped working after update… when in debug and " tail -f .kodi/temp/kodi.log |grep OnKey:" i don’t see the up, down, left, right any more…

Unplug your TV from the power to completely reset it then turn it back on and reboot OSMC. As Sam says no CEC changes have been made recently.

1 Like

yes, that did the trick. very odd behavior.

Yes. Some TV’s get confused when Kodi exits and restarts (which will often happen while upgrades are being installed) and this sometimes puts the TV in some different mode where different CEC button codes are sent for the same buttons. (The TV thinks a different kind of device has been connected, probably)

If you check your log when the problem was occurring you’ll see that the CEC codes that Kodi is receiving for the buttons that are not working are not the normal codes but some others shown as hexadecimal numbers that don’t have any mapping in Kodi - thus they appear in the debug log but don’t perform any action.

CEC is a really complicated protocol with a lot of differences in implementation from one vendor to another - it’s amazing that it works as often as it does… :slight_smile:

good to know, thanks for the info!
anyway, next time i’ll be losing my remote, i will first restart my tv and then post to the forums :smiley:

My yamaha receiver CEC is working now. I have tried many hdmi cables but nothing happens, today I reset my RPI CEC settings and after that receiver remote start working :smile:

Hi martyn… How did you reset the RPI CEC settings?
I’ve tried everything, including restarting the TV but didn’t work.



I load cec default settings, switch off all startup and shutdown settings. Where is the “Connected to HDMI device”, there I choose Amplifier. Hdmi port 1, remote button press delay 50ms. After that I restart rpi and my yamaha remote works