Lost network after recent update

Again, the latest update ("… Kodi needs to exit. Do you want to do that?" or similar) surprised me with the incapability to access the network via Wifi.

First incident was when I tried to watch a movie and Kodi said “not available any more. Delete from library?” or similar. I restarted Kodi, tried again, the same. Noticed Kodi didn’t obtain an IP address. Rebooted again. Kodi got an IP address. Tried to watch movie, this time: absolutely unresponsive. Rebooted. Tried to SSH into it. Took a couple attempts. After finally logged in, sluggish and slow and laggy. Keypresses delayed. CPU according to Kodi’s UI ~2%.

Activated logging. Rebooted. Tried to reproduce. No reaction, CPU/FPS counter not changing. After 5min, hit the “Back” key on the remote. Re-SSH’d into it. Wanted to ‘grab-logs -A’, came back with

osmc@osmc:~$ grab-logs -A
Logs successfully uploaded.
Logs available at https://paste.osmc.tv/<html>

Tried to use MyOSMC’s log uploader. After a while it came back with

URL: https://paste.osmc.tv/<html>

At least, after a ~5 min waiting time, Kodi reacted, and I could watch the video.

So. How can I get rid of the delay, and what is happening to the log uploader?

Can you attach an Ethernet cable and check for updates again?
There was an update a while ago that caused problems with WiFi but this has since been fixed. If your device cached the old update, it’s possible you updated to this version.

Please reboot and upload new logs after trying the above.

Hey Sam,
thanks for your answer.
I did that a while ago: No wireless connection - #2 by sam_nazarko

Usually logs won’t upload if they are too big.
Can you try rebooting and try upload again?

I rebooted. SSH’d into it, kodi.log 8.4MB, kodi.old.log 59K.
Used MyOSMC > Log Uploader. Result the same: URL: https://paste.osmc.tv/

Rebooted again. SSH’d. kodi.log 145K, kodi.old.log 8.5MB.

Rebooted again. SSH’d. kodi.log 142K, kodi.old.log 263K.
Used MyOSMC > Log Uploader. Result the same: URL: https://paste.osmc.tv/

From the running time of the log uploader i’d guess that the logfile maybe somewhere on paste.osmc.tv, but no one knows where.

There’s a limit of 10MB post size.
Can you stop Kodi (systemctl disable mediacenter) and reboot? The issue with networking won’t be caused by Kodi. You should then be able to upload logs.

Let’s do smaller steps.
grab-logs -K -J -n
dmesg | paste-log

1 Like

osmc@osmc:~$ grab-logs -K -J -n
Logs successfully uploaded.
Logs available at https://paste.osmc.tv/
osmc@osmc:~$ dmesg | paste-log

Please note that https://paste.osmc.tv/ is literally https://paste.osmc.tv/<html>

Perhaps something has become a bit corrupted.

You can try to send the log to a file on the SD card: /boot/uploadlog.txt

grab-logs -A -C

If the file is less than 10 MB, you can upload it using paste-log /boot/uploadlog.txt, since we know that paste-log is working. If it’s greater than 10 MB, use a file sharing site, such as dropbox.com or volafile.org

Ok this one worked, so we at least have a first starting point.
But what is really strange is that this file only starts 8 seconds into the boot process
[ 8.026754] hdmitx: fs = 2, cd = 4, tmds_clk = 148500

So just first to recap a bit, you are generally connected via Wifi which broke with the latest upgrade and now for uploading the logs you are connected via Ethernet?

Can you run this command and share the URL.
dmesg | grep dhd | paste-log

I’m watching this, but the logs aren’t complete, so hard to advise yet.
If journalctl doesn’t work, I’d suggest backing things up (copy ~/.kodi) and reinstalling OSMC

After backing things up and reinstalling, would I have to pair my Bluetooth remote (Logitech Harmony) again?

Yes, if you only backup the .kodi folder the system settings like bluetooth pairing will not be restored.

As written, maybe one last try on the last log command I have sent you before reinstall.

Uh… pairing Harmony with OSMC is something I’d want to avoid.

dmesg | grep dhd 

was empty before a restart. So I restarted and pasted the logs to

Not aware that that would be difficult at all maybe some Harmony users can comment here.

Maybe @sam_nazarko can check this log, some part look strange.
Could you also reply me question so that we exactly know current situation?

Last but not least to ensure that was not overlooked, I assume you did another update try when you connected via Ethernet, or?

Not difficult at all to repair harmony units.

Try run connmanctl enable wifi

@Toast, is there any guideline by which I could proceed?

@sam_nazarko, @fzinken, thank you very much. Wifi is enabled. I am connected via Wifi. I have not used cabled Ethernet to upload logs. I also did not try another update, because I have already the latest update.

The current status is: the situation eased up a bit. For the last couple restarts, vero got an IP address via wifi, and immediately (without waiting ~5min) was able to access the network. I am not aware of a change I made in vero. I first thought that maybe my NFS server was hicking up, but the message “could not reach network” from the weather plugin and the inability to SSH into vero speaks against that.

It feels like OSMC needed a certain time or a certain amount of reboots to come back to normal operation again. Is that possible? I rebooted at least 10 times in the course of like 24 hours before I posted this thread.

Remainder of the situation: After leaving vero idle for ~16 hours, I tried to start a movie. OSMC froze up for a couple moments and came back with “not available in library any more. Delete?”. I am using autofs. So I had to reboot. Why is osmc unable to revisit the video library?

I left OSMC unattended for ~8 hours, same behaviour: selected a movie, but couldn’t be played because “missing in library”. Luckily I had the log option turned on. I had to save the logfile to SD card, because the log uploader wouldn’t upload it. SSH access also was not possible.
Tried to upload the file after a reboot, but the log is 42M big. I’ll copy it to a safe place until you tell me what to do with it :slight_smile:

A wifi AP placement guide: The Ars Technica semi-scientific guide to Wi-Fi Access Point placement | Ars Technica might be helpful.

Wifi needs to be a separate issue from everything else, since issues with OSMC cannot really be worked until the network problem is solved.

I’m always surprised when people use NFS over wifi. I suppose it would be ok with read-only mounts. I’ve always been too afraid of data corruption to use NFS with wifi. But it is your data.