Lost remote controll support

I recently lost the ability to control my Raspberry 2 running OSMC with my TV remote.

I have a fairly new Samsung TV and the remote that came with it. It’s been working flawless for controlling OSMC for months. It worked out of the box - I haven’t done any settings to get it to work, as far as I can recall.

Just a few days ago, the remote no longer work for OSMC. Still works for the TV.

I have recently set up a soundbar system to the TV (via HDMI), but I believe the remote still worked after that. In either case, removing the soundbar doesn’t give remote control back.

I also installed updates to OSMC at about the same time, probably after setting up the soundbar. I think it’s more likely the problem arose from there.

I have checked My OMSC for remote settings, but so far without any luck in getting the remote back online.

Any ideas on how to fix this?

Have a search

If you’re using CEC, there was a bug on Saturday and this has now been addressed

Yes, I’m using CEC. I have tried searching for this issue, both before and after I posted this thread, but my google fu seems to be failing me and I find nothing.

All the while, my problem persists. I’ve installed updates twice since I posted the thread.

Unplug OSMC and the TV from power for a few minutes. Then plugin the TV and start OSMC afterwards