Lost touchscreen and iqaudio soundcard after November upgrade

I have an OSMC box built upon a Raspberry pi 3 with the Raspberry official touchscreen and an iqaudio DAC+, all connected on the GPIO using the manufacturers instructions.
It worked well for years.
There have been countless automatic OSMC upgrades without troubles.
This morning, I accepted the upgrade from OSMC and, afterwards, both the sound card and touchscreen functions have vanished.

The config.txt has not changed. The iqaudio is still enabled in it. But it can’t be used in the audio settings.

I saw no config change for the touchscreen. and it looks like it is detected (excerpt from dmesg):

[ 1.669223] mousedev: PS/2 mouse device common for all mice
[ 1.669564] usbcore: registered new interface driver usbtouchscreen

Any hints about how to fix this?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

I can see the problem now.

This should now be solved, simply check for updates again.

Really ? I was just busy enabling logs right now. :grin:
Do you mean you don’t need them anymore ?

Test the update and see :wink:

Yes ! It worked perfectly !
Everything is back to normal. Thanks a lot @sam_nazarko ! I am astouned by the quickness of this fix.
Out of curiosity: what was the problem?