Loud pop on radio add on

When selecting a radio station using the kodi radio add on a loud pop occurs, loud enough for me to be worried about damage to my speakers. This happens with most, but not all stations.

I’m using RPi3 and IQaudioDAC to aux input on Pioneer amp.

Any help to resolve this would be appreciated

Have you tried the settings at Settings->System->Audio

  • keep audio device alive: always
  • send low volume noise: on


Yes I’ve tried this but no difference.

I’ve tried installing a different radio addon and the problem remains

Does it only happens when playing from Addons and not e.g. when you switch from one Album to another one?

I just tried on my system where I have a Hifiberry DAC+ with Aux and can not replicate it.

Only with radio addon. No problem playing albums or video

As mentioned can not replicate. Does it happen if you use the headphone plug instead of the DAC?
Otherwise maybe check Kodi Forum if anyone had seen something like that.

I’ve found that the lines in config.txt,



have somehow changed to


Could this be the problem?

However when I try to edit them in myosmc the changes are not being saved after rebooting. Might this be a SD card problem?

Try touch /boot/testfile, shutdown, restart and see if testfile is still there.

As a last resort I’ve done fresh instal of osmc on a new sd card, added the radio plugin and the pop is still there! If I disable the DAC and play through the tv there is no pop. I guess this indicates a fault with the DAC?

I would nag the people who wrote the DAC driver. If it’s implementing a standard ALSA interface, they should make sure the thing is muted when any parameters are being changed.

Although it is odd you have problems with only that add-on. It must be doing something that Kodi and HiFiBerry can handle nicely while your DAC (driver) can’t.

I’ve swapped the iqaudio dac for a hifiberry. Still popping.

I’ve just noticed that the pop only occurs on the left stereo channel, not the right

If I swap the output phono plugs over the pop changes to the right channel.

After switching the default audioplayer to videoplayer the loud pops when starting audio network streams are gone:


<?xml version="1.0" encoding="utf-8"?>