Loudness variations while playing recording / live tv

Hi, I’ve been using xbmc and kodi for many years now and like the program a lot!
I’m running kodi on a rpi B and I’m using OSMC (details are below).
The audio is played via a set of desk top speakers (with built-in amplifier) connected to the the mini jack connector.
Since a few months I’ve been experiencing odd volume changes while playing live tv or recorded tv programs.
The sound will become much louder than it was for a few seconds and will go back to the level it had before that.
If this happens while watching a recording if I replay that bit, the volume change will reoccur, so the volume change is in the recording. When I’m watching live tv this may happen once or twice every half hour or every hour (the interval time is not constant).

In the audio and subtitle settings (the menu that pops up when pressing play while already playing) the ‘volume’ is set to 0 dB for maximum output. The Volume Amplification is completely ignored! This I used in the past to get some more juice to my speakers but has stopped working over the years (I’ve not found a reason for this).
Other settings: Stereo-upmix is off, Outpout configuration is fixed, keep audio device alive: always,
Resample quality: GPU acceleratied

My questions: has anyone experienced similar volume changes and / or does anyone know a remedy for this?



osmc@pi4:~$ grep VERSION_ID /etc/os-release
osmc@pi4:~$ grep Kodi .kodi/temp/kodi.log | head -3
18:14:44 26030.531250 T:3023872944 NOTICE: Starting Kodi (16.1). Platform: Linux ARM 32-bit
18:14:44 26030.531250 T:3023872944 NOTICE: Using Release Kodi x32 build (version for Raspberry Pi)
18:14:44 26030.531250 T:3023872944 NOTICE: Kodi compiled Aug 28 2016 by GCC 4.9.2 for Linux ARM 32-bit version 3.16.7 (200711)


Have you got Volume Amplification set to 0?
That is the obvious reason for volume changes.

Why is this obvious? I would think by setting it to 0 it would be at the maximum volume setting. Please explain your reasoning.

I meant not being set to 0 would be the obvious reason for volume fluctuations.
If it is set to 0 I can’t think of any reason for volume changes.