Low colour saturation Vero 4k

That’s interesting. Can you tell me what the line would be and where to put it please?

See Low colour saturation Vero 4k - #9 by tgrun

Try putting it in /etc/rc.local before exit 0, or before setting anything permanently:

  • Boot up
  • Run sudo systemctl stop mediacenter
  • Type sudo -s
  • Run echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb before playing anything
  • Run sudo systemctl start mediacenter
1 Like

Actually, I have to retract my comment about the dark colours at startup being fixed. It just didn’t occur one time… But now it happened again. So, NOT FIXED here either :wink:

Were you playing the same clip in both tests?
The fix isn’t for HDR -> SDR; it’s for Philips TVs or TVs not reporting their colourspace caps properly.

After the next update (due shortly), I’ll make a test thread with some tests for HDR and 10-bit output.


Sry, @sam_nazarko, I was just referring to this issue… :wink: Pardon me creating confusion!

I have a Vero 4K connected to an older Philips television. Previously using the output_rgb command remedied the saturation issue (I added it to /etc/rc.local).

But after the latest OSMC update (July 2017.07-1) the problem occurs more frequently and the fix doesn’t appear to be working. When I enter the command as root I get a permission denied error.


I expected this might trip some people up.

Can you try:

echo 'rgb,8bit' > /sys/class/amhdmitx/amhdmitx0/attr

If this doesn’t work I’ll take a further look and get this solved. We had some 10-bit colour improvements in this update which has caused some changes. This completes the final stage of the new video scheme; which means from here on we won’t have any nasty surprises.


The command work and it seems to do the trick! Haven’t had the saturated greens during the five minutes I’ve tested. Will try some more tonight and let you know if anything out of the ordinary happens.

I’m glad to hear that.


Hm, I spoke too soon. After a while the saturation goes wonky again. The command above doesn’t remedy the situation, I’m afraid.

When you say after a while? Is this after multiple videos? Does disabling Adjust Refresh Rate resolve the issue temporarily?

Do you have an AV receiver between the TV and the device?


No, this is during a single video, about fifteen minutes in. After changing the refresh rate in the settings menu the issue is temporarily resolved, but happens at irregular intervals. I can’t find the setting to disable “Adjust Refresh Rate” (Kodi settings level is set to Expert).

My television also flashed to black for a second after switching to the HDMI input of the Vero and starting a video. My Vero is hooked up to the television directly, so no devices in between.

It’s flashing for a second because you have Adjust Refresh Rate enabled

You could try disable this under Playback settings.

The colours are probably reset if your TV deasserts when the Refresh Rate is changed.

I think the setting is under Settings > Player > Videos? “Adjust display refresh rate” is set to “Off”. I experience the black flash when navigating Kodi’s menus as well.

Just random flashes? That shouldn’t be happening. Is this a new issue since the update? If so – does installing an older version, such as June resolve the problem?

Try another hdmi cable and make sure the power supply is direct in to the wall (no extension chord)

Just the one black flash as soon as the television wakes from standby or has just powered up. It’s a recent problem, after echoing rgb,8bit to /sys/class/amhdmitx/amhdmitx0/attr and adding it to /etc/rc.local. I’ll remove the line and see if it occurs without it as well.

I had the Vero on while typing the previous post and it flashes to green in the menus as well, not just when playing a video.

Ah - are you saying that the issue occurs when you take the TV out of standby? That means your TV deasserts so the command needs to be run again (I suspect if you run the command again manually when it goes green it will fix it)

Sorry about the questions but the issue isn’t entirely clear

No problem! I’ll try to break the two issues apart, for clarity’s sake.

The black flash seems to occur when I put my tv on standby, wake it up and the black flash is there a few seconds after it’s fully booted up. It’s not that big of a deal, because it only happens once.

The green flashes occur irregularly and frequently both when playing videos and when navigating through Kodi, there doesn’t seem to be a real pattern or length to it. Echoing 'rgb,8bit' doesn’t fix the green saturation, I’m afraid. The saturation also seems to be permanent until I change the refresh rate to an arbitrary number in Kodi.

That is probably the TV renegotiating with the Vero 4K and the TV likely deasserts when it goes on standby. That’s not unexpected.

Do you have another (non Philips TV) to test this on? It would be good to confirm this is indeed caused by this TV. And just to confirm you do still have [quote=“sam_nazarko, post:23, topic:37483”]
echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb

in /etc/rc.local as well as the newly suggested command?