Low colour saturation Vero 4k

Hi, I am a new Vero4k user coming from the Windows HTPC world and hope that you can help me out.

I have a problem similar to what has been mentioned in several other threads here already, namely washed out colors / low colour saturation (blacks are not displayed as blacks but grey etc …) so the problem is likely to come from a wrong RGB range Full/Ltd or YCbCr output.

I spent the last few hours browsing the OSMC forums here but unfortunately none of the solutions posted worked for me.

The colours upon booting Vero4k are CORRECT, ie the Kodi/OSMC interface has the correct colours at startup.
But as soon as a video starts playing (any video, tested many), the colour space changes and blacks are no longer black etc … when I stop a video from playing that wrong colour space persists, ie the Kodi/OSMC interface now has low colour saturation until a full reboot. I am unable to get any video to play with proper colours.

I have tried running

echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb

while a video was paused as suggested in several other threads but I get

-bash: /sys/class/amhdmitx/amhdmitx0/output_rgb: Permission denied

I ran that command via a Windows PC using Putty logged in as default osmc user. Is there a possibility to login as root in order to get that command to run ?

Here’s the output of some commands you usually ask from users in order to better address the issue:

cat /sys/class/amhdmitx/amhdmitx0/disp_cap
480i60hz
480p60hz
576i50hz
576p50hz
720p60hz
1080i60hz
1080p60hz
720p50hz
1080i50hz
1080p30hz
1080p50hz
1080p25hz
1080p24hz
2160p30hz
2160p25hz
2160p24hz
smpte24hz
smpte25hz
smpte30hz
smpte50hz
smpte60hz
smpte50hz420
smpte60hz420
2160p50hz
2160p60hz
2160p50hz420
2160p60hz420

cat /sys/class/amhdmitx/amhdmitx0/rawedid
00ffffffffffff004c2d3b0d00060001011a0103807944780a23ada4544d99260f474abdef80714f81c0810081809500a9c0b300010108e80030f2705a80b0588a00501d7400001e023a801871382d40582c4500501d7400001e000000fd00184b0f873c000a202020202020000000fc0053414d53554e470a2020202020012a020350f05761101f041305142021225d5e5f60656662636407160312290907071507503d04c083010000e2000fe305c3016e030c002000b83c2010800102030467d85dc401788003e3060501e30f01e0011d80d0721c1620102c2580501d7400009e662156aa51001e30468f3300501d7400001e0000000000000000000000ab

Thanks for your help.

run the command with sudo or su root first.

I know what this is. Will fix it shortly.

Sam

Hi Sam, got my Vero yesterday and am very happy with it, but I have a colour/picture question too.

I have a 4k tv but it doesn’t have HDR. I do have some .mkv files 2160p 10bit with HDR that look fantastic when played through my Samsung uhd player, but when played through the Vero they are very dark and colourless, to the point of being unwatchable.

On the Samsung deep color is set to auto and hdmi color format is ycbcr (4:4:4). There are no settings like this on the Vero are there?

Any specific reason for this, have you come across this before?

I did see on another post where users were having an 8-bit/10-bit color problem that you posted “There is a new scheme coming which will allow more detailed sysfs approach to video configuration. This will allow full control over colour depth from userspace” so maybe this will help.

Regards,

Jason.

Thanks, I tried that already but I don’t know the root pw and I don’t think it has been provided anywhere.

@sam_nazarko, can users get the root pw in order to try this ?[quote=“royleijiang, post:2, topic:37483, full:true”]
run the command with sudo or su root first.
[/quote]

thanks Sam

Well everyone can run root commands (using sudo).
Also reading the wiki helps

https://osmc.tv/wiki/general/usernames-and-passwords/

cheers for the link, I did spent many hours on the forums and wiki but did not come across this one

@sam-nazarko

running

echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb

as root did not have any effect on the colour space during a paused video and after stopping the video the low colour saturation still prevailed in the Kodi interface

Spooky, I was going to ask the same but I use limited rgb on my tv so I have the opposite issue. At reboot things are too dark. As soon as I play something they lighten up and are correct though.

I assume your fix will work both ways will it Sam?

Thanks

-Mat

That’s a different issue but I am aware of it and it is indeed
on the list

Cheers

Sam

1 Like

Thanks Sam. Sounds like the next release is going to be major and fix lots of display issues :grinning:
-Mat

Has there been a new build to fix this then? I’m still seeing things too dark initially.

-Mat

Yes, there have been even 2 builds since before I reported the issue resolved for me…

Why do people not update their Vero? It does even give a popup for updates automatically.

I updated manually on Monday I think and that didn’t fix my issue. As far as I know that was a security update wasn’t it.

I’ll check for another update tonight then.

We still have the ‘smearing’ issue on hardware decoded h264 files though don’t we? I don’t think Sam has done a ‘full update’ to fix all display issues has he?

As to your other question, I have switched off auto update since I like to know what’s going to be updated before deciding whether I need/want it.

Thanks

-Mat

Correct – not yet, but a few colour issues were fixed. Some users had problems reporting colourspace incorrectly (happens with old Philips TVs) which is a separate issue to this one.

Cheers

Sam

Thanks Sam,

I assume my issue is not colourspace related but black level then? I have my LG TV set to use limited (16-255) and have a wonderful picture through my other devices (BD, Humax DVR, Chromecast and just normal TV). It’s as if after each reboot the Vero is using 0-255 for black level.

With my pi3 I used to use ‘hdmi_pixel_encoding=1 RGB limited (16-235)’ but can’t find a way to do that with the Vero - is it just a question of adding that line to a config file somewhere? config.txt doesn’t exist does it so how about advanced_settings?

I have found that, despite the dark startup picture, if I’m using a hardware decoder (which I’m not as you know at the moment :slight_smile:) as soon as I play something the picture lightens and all is ok until a reboot. This does not seem to work under the software decoder though. So after each reboot, I have to re-enable the hardware decode, play something for a second to make the screen use the right ‘darkness setting’, then disable the hardware decoder again. Bit of a first world problem, but I’m looking forward to you fixing it Sam :smile:

Thanks

-Mat

There should be a setting for this in Kodi itself according to the Kodi wiki.

Edit: although… it’s dependent on the hardware if it’s there or not.

Interesting. this from the link:

Kodi can be set to use limited video levels through the settings menu.
NOTE: There is a limitation of the VAAPI Hardware Decoder where it converts to Full video levels despite setting Kodi to use limited. To get limited video content to output from Kodi, you must disable hardware decoding in Video Settings for the time being. This will be fixed in Kodi 17

Vero 4K doesn’t use VAAPI.

The output_rgb option can be used if that’s your issue.
It has the same effect as the Pi option you mention above.

Cheers

Sam