[TESTING] 10-bit, HDR and dithering improvements


Your edits are very detailed. I checked this when I woke up and had some questions to ask, but after finishing the day and planning to get back this I see that you’ve answered some already.

I’ll follow up on this shortly (when less tired)

Thank you for the verbose report



No worries, have a look when you get a chance.
It still not good right now. After watching some stuff it seems the TV won’t accept the signal at random (420,10bit @ 4k60hz), and running hdr material can just end up in garbled lines all over the screen. I don’t know what the problem is at this point tbh. The TV won’t accept 4:4:4 unless in PC mode (which limits all movie options) and it won’t accept 4:4:4 in HDR at all. This seems to be a known issue and affects all LG (oled?) tvs. If I force 4:2:0 it kinda works, but HDR is still hit/miss and sometimes it just cuts to black. This also forces me to run Kodi at 4k60 and can’t enable “adjust refresh rate”.

I’m gonna try reinstall the regular build and see how well that one works. What are the main differences with this experimental build?
Would be nice to have someone else with a LG tv confirm if possible :slight_smile:

Edit: I just now realized that the TV can actually play most files from the NAS via DLNA, and I can successfully play all these HDR10 4k files without issues. I also noticed that DTS-MA 7.1 now gets correctly passed through (as DTS) (via kodi it would show as 5.1 but not DTS). With the freshly installed OSMC all files worked normally, but it’s 8bit I believe (there’s flickering/banding in skies like that video I uploaded) but there’s no crashing/losing signal at least.
Perhaps I’ll use the Vero as a 1080p/4k (non-hdr) player and use the TV for HDR content. This will also let me use DTS-HD (my amp supports it but it’s only hdmi 2.0 so can’t send 10bit/hdr to the TV).

Are there any more options for the amhdmitx device that I can fiddle with? With the current release I tried forcing RBG but that didn’t make anything better.

Edit2: Running the experimental build via my amp (Yamaha RX-V475) I can now play 10bit HDR content! I have to keep the attr as 444,8bit though, since my amp doesn’t do 10bit/hdr. With the regular june version all hdr content would just get gray/washed up, but now they play like normal movies. So I guess for now the Vero will do all my 1080p/4k and the built in TV player will play 4k HDR material.

1 Like

If you enable Sync Playback to Display, you’d get away with this

For now it seems that there are issues when changing mode. I think the process of changing the mode is racy.

Yes, dithering will be improved. I’m glad to hear this.

Tested the fix today, too… I had issues playing Billy Lynn’s Long Halftime Walk in the 2160p60 HDR version. I couldn’t find a 1080p60 version in SDR (I only own a 1080p TV), so I had to stick to this one.
The dithering (false coloring) is gone now!

But I noticed that VQ is constantly running low to 0% about once every minute resulting in massive skips. But this isn’t a dithering/HDR issue, I guess. @sam_nazarko, how and where should this be adressed? Is this issue already known to you?

It’s not.
Are you playing via SMB still? If so – can you try fstab based mount. It may just be that you are playing higher bitrate content than normal and didn’t notice this before.

Since the 1080p skipping issue I’ve stayed with fstab mounting…

Could be similar to some buffering issues @f0o is also experiencing with high bitrate content. It’s being looked in to, but likely won’t be related to the changes made available in this thread. I’m glad that colours look better now.


1 Like

But what I can confirm already: the dark color startup bug that has been reported and not fixed yet, seems to have gone with this test kernel.

Just to make sure, I did as advised (after that the bug was gone for me after every reboot):

wget "https://www.dropbox.com/s/jjt87mtlyxic3l1/vero364-image-3.14.29-25-osmc.deb?dl=1" -O vero3-image.deb
wget "https://www.dropbox.com/s/bpyaqkr3azx5nsc/vero3-mediacenter-osmc.deb?dl=1" -O vero3-mediacenter-osmc.deb
sudo dpkg -i vero3-image.deb
sudo dpkg -i vero3-mediacenter-osmc.deb
sudo reboot
sudo chown osmc:osmc /sys/class/amhdmitx/amhdmitx0/frac_rate_policy

I thought in PM the other day you said it was still not fixed? I had assumed you had tried the testing kernel: the issue isn’t fixed in the current stable kernel


Sry, that was a misunderstanding then. I was referring to the stable kernel :grin:
The issue is gone in the test kernel.

That is good to hear


i can not edit the rc.local (for 10 bit display), because “permission denied”. I was connected by sftp via Filezilla…

Any idea?

Many thanks!
BR Peter

Suggest you use SSH to access the box. You’ll also need to use sudo to get elevated privilege when editing rc.local.

See Accessing the command line

Thanks for reply! I was connected via SSH, but don’t know how to edit the rc.local… For this i try to use filezilla. Could you give me a further hint?

BR Peter

Use sudo nano /etc/rc.local


Many thanks for helping out! After procedure OSMC shows update available, will this overwrite the test build again?


I’m pretty new to the Vero 4k, but I have tried one 10bit 4k movie which is looking much better with this build. Can’t really say anything about the banding issue. I do however experience occasional blackouts. Full debug log here: https://paste.osmc.tv/qapopigapi


10bit Picture-depth is working well with this build; But there is no switching between 8 and 10 bit, right? It stays at 10 bit also for 8 bit content. Was this your intention?

Great work + hope to see this “feature” official!


Yes – this is expected.

This functionality will be implemented in the next update. Thanks to everyone in this thread for testing and helping us prepare it for OSMC :thumbsup:

Closing this thread as the above improvements are now in OSMC’s July update