[TESTING] 10-bit, HDR and dithering improvements

This is experimental. You have been warned.

Over the past few weeks there have been a few of you trying HDR and 10-bit content and reporting issues with colours or slight banding. Here are some experimental test builds that will hopefully improve this situation.

Please note that this is early days; and these builds are quite experimental. I would recommend that you take a backup before installing these builds.

In this build:

  • Colourspace should now be passed for content
  • Banding when playing with 8-bit output should now be fixed

Installation:

To try these improvements, please log in via the command line, and run the following commands:

wget "https://www.dropbox.com/s/jjt87mtlyxic3l1/vero364-image-3.14.29-25-osmc.deb?dl=1" -O vero3-image.deb
wget "https://www.dropbox.com/s/bpyaqkr3azx5nsc/vero3-mediacenter-osmc.deb?dl=1" -O vero3-mediacenter-osmc.deb
sudo dpkg -i vero3-image.deb
sudo dpkg -i vero3-mediacenter-osmc.deb

If you have a 10-bit capable display; please add the following to /etc/rc.local before the exit 0 line:

echo '444,10bit' > /sys/class/amhdmitx/amhdmitx0/attr

Now reboot your system with sudo reboot

Might want to include method to revert :wink:

Just in case

AWESOME! This is working great for me. I can confirm that my receiver & TV are both receiving a 10bit signal from the Vero4k with no ill effects. I watched plenty of 10bit content and it looks considerably better now, and there isn’t any negative effect on 8bit content, although it does always seem to output a 10bit BT.2020 signal regardless of the bit-depth of the content (don’t see any problem here, just reporting everything I’ve noticed. It was always 8bit before regardless of whether it was 10bit content).

2 Likes

Thanks for confirming.

I will now re-list the post so it’s publicly visible and we can get further testing

There may be other regressions, as there are a lot of upstream changes from the SoC vendor, but that’s why we have a test thread after all :slight_smile:

Sam

Actually I just noticed one thing - my harmony remote stopped working again. I didn’t change anything regarding that config. It was working fine as an Xbox 360 remote using lircd before the update.

There may be breakage, but that goes with the territory. I’d like to focus on the video improvements for now in this thread, but if you send me a PM we can debug this further. The latest SoC changes may have an impact on IR support.

That why we’re still testing :slight_smile:

Sam

1 Like

Thank you for this Sam, just tested and HDR looks great now. I never noticed 8-bit banding to begin with, I have to say.

I didn’t really see any issues with HDR but decided to try this anyway and it messed something up.
I had a pretty fresh install and updated with this. Now on boot it won’t load the NFS shares setup in fstab (seems to try to mount them before wlan is finished), and OSMC crashes one time (Sad face but restarts again) and now when I try to watch one HDR10 clip that was previously okay it clips to black and resets the display a few times, and when there’s image there are red pixels scattered. Very strange.

Something I found in the logs

rc.local[390]: /etc/rc.local: 13: /etc/rc.local: cannot create /sys/class/amhdmitx/amhdmitx0/attr: Permission denied

After a few reboots the red pixel issue seems to be gone (note this was only for one file).

Is there an easy way to roll back or should I just reinstall and restore my backup?

I don’t think you edited rc.local correctly; so it’s causing boot issues.
Please paste the output of your rc.local.

I haven’t really touched it more than pasting that line:

#By default this script does nothing.
echo ‘444,10bit’ > /sys/class/amhdmitx/amhdmitx0/attr
exit 0

Then it sounds like the kernel didn’t update properly. Can you try rerunning the above commands again and paste the output?

Also: what is the output of ls -l /sys/class/amhdmitx/amhdmitx0/attr

osmc@osmc:~/temp$ sudo dpkg -i vero3-image.deb
(Reading database … 21343 files and directories currently installed.)
Preparing to unpack vero3-image.deb …
Examining /etc/kernel/preinst.d/
Done.
Unpacking vero364-image-3.14.29-25-osmc (25) over (25) …
Examining /etc/kernel/postrm.d .
Setting up vero364-image-3.14.29-25-osmc (25) …

Hmm. There is a symbolic link /lib/modules/3.14.29-25-osmc/build
However, I can not read it: No such file or directory
Therefore, I am deleting /lib/modules/3.14.29-25-osmc/build

Hmm. The package shipped with a symbolic link /lib/modules/3.14.29-25-osmc/source
However, I can not read the target: No such file or directory
Therefore, I am deleting /lib/modules/3.14.29-25-osmc/source

Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.14.29-25-osmc /boot/vmlinuz-3.14.29-25-osmc
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal-osmc 3.14.29-25-osmc /boot/vmlinuz-3.14.29-25-osmc
run-parts: executing /etc/kernel/postinst.d/inform-updater 3.14.29-25-osmc /boot/vmlinuz-3.14.29-25-osmc
run-parts: executing /etc/kernel/postinst.d/upload-to-emmc 3.14.29-25-osmc /boot/vmlinuz-3.14.29-25-osmc
7+1 records in
7+1 records out
8056832 bytes (8.1 MB) copied, 0.596019 s, 13.5 MB/s
0+1 records in
0+1 records out
40465 bytes (40 kB) copied, 0.0365343 s, 1.1 MB/s

osmc@osmc:~/temp$ sudo dpkg -i vero3-mediacenter-osmc.deb
(Reading database … 21677 files and directories currently installed.)
Preparing to unpack vero3-mediacenter-osmc.deb …
Unpacking vero3-mediacenter-osmc (17.3.0-4) over (17.3.0-4) …
Setting up vero3-mediacenter-osmc (17.3.0-4) …
Processing triggers for mime-support (3.58) …

osmc@osmc:~/temp$ ls -l /sys/class/amyhdmitx/amhdmitx0/attr
ls: cannot access /sys/class/amyhdmitx/amhdmitx0/attr: No such file or directory
osmc@osmc:~/temp$

I don’t remember it saying those “hmm” things the first time but perhaps something’s messed up then, and there doesn’t seem to be an attr that I can list :frowning:

Typo.
Reboot and try again.

This update changes nothing with NFS. Did you recently make changes to fstab? What’s it look like?

Rebooting

fstab just looks like

192.168.0.200:/volume1/Movies /home/osmc/Movies nfs noatime,async,nfsvers=3,nolock,local_lock=all,soft,retrans=2

which works fine now if I sudo mount -a, but it seems the wifi isn’t connected when he tried to connect on boot

osmc@osmc:~$ cat /sys/class/amhdmitx/amhdmitx0/attr
444,10bit

So that part seems to be working fine now :slight_smile: Still not sure why it’s trying to mount NFS before wifi is done. Not a major issue but weird nonetheless

I’m still having issues playing the video though. It was working fine before, so not sure what’s going on.

edit: also, now upon booting the linux kernel boot text stuff is shown over the osmc background, didn’t use to do that either.

Hi Martin,

Dropped you a PM in regards to your nfs issues, so the topic doesn’t become cross threaded.

Thanks Tom.

Yes - because you aren’t using x-systemd-automount.
That’s not related to the above changes. Your current fstab doesn’t wait for network.

Likely because your mount is failing on boot, because you aren’t waiting for network to come online.
I’m sure Tom will help you out.

1 Like

Hi and thanks, that did the trick. X-systemd solved it.
Now the shares and boot looks fine, however hdr videos are still cutting/going blank and showing red pixels :frowning: regular material works just fine