Low download speed on new 4k+

Hi. i recently bought a new Vero 4k+ and when i ran a speed test in kodi. i’m getting 10mb down and 2 up. I have 400mb download thru my cable provider. I run the vero box from my router to the box with a cat 6 cable. When i speed test my pc i’m getting equal or above my 400mb speed. i did read some posts on here but most talked about running thou switches and all. i’m not real tech smart so i need help figuring this out. My route is a Netgear Nighthawk Pro Gaming XR500. i tried resetting factory resetting my router and power cycled the modem.

See [How To] Check Network Performance with iperf3

How do I install this? I don’t have a way to do sudo commands? And it said something about wireless. I’m running a wired connection. Sorry I don’t understand this stuff

Well on the Vero you should be able to run sudo commands when you login via command line (e.g. SSH) which is explained in below link. Then just install iperf3 on your PC (depends on your OS) to test Vero to PC speed.

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

Thank you. I’ll try that.

Can you elaborate on exactly how you ran this speed test?

I used speed test app on Kodi

That’s testing an external factor. Ideally you should use an iperf test to check your internal network first

Sam

I assume you mean speed tester (powered by speedtest.net), I didn’t even know that existed in Kodi. I tried it on a few machines and i’m not sure about the accuracy of what it is reporting. On my PC it reports 100Mb/s slower using the Kodi add-on than their web interface on the same machine. My RPi 3 is only reporting 40/40 while my RPi 4 reports 450/40 even though they are connected to the same switch and sitting right next to each other. My actual real internet speed is 850/40.

I’m going to try the iperf and I’ll get back to you with results.

here is the iperf3 data. https://i.imgur.com/bKJtVam.jpg
the top test is just -c the bottom test is -R -c

That is full Gigabit speed, which means that there is not an issue with the Vero 4K + or your internal network.

then why was the speedtest only showing 10mb? and why does it buffer so much?

as i said i have no idea about this stuff.

The speedtest would be evaluating the speed of your Internet connection, rather than your LAN connection.

Where are you streaming from?
Have you tried something like YouTube?

Well besides the fact that speedtest can be impacted by many points surely the one within Kodi is not reliable. If you want to still test the Internet Speed instead of just your internal network (which you did with iperf3) you can use some public iperf3 servers
https://iperf.fr/iperf-servers.php

Or install command line speedtest
sudo apt-get install speedtest-cli

Here are my Vero4k values
Testing download speed…
Download: 60.86 Mbit/s
Testing upload speed…
Upload: 89.88 Mbit/s

tried watching stuff on youtube you mean? yes
streaming from? you mean what country or what?

A lot of gaming routers have QOS or some other gamer marketing wank sounding feature/s that will automaticly throttle certain devices internet connection to maintain maximum speed for other devices. You may want to have a poke around in your router’s settings.