Low WiFi bandwidth in data reception (iperf)


I have some issues with my Vero4k+ with Wifi.
The following command line delivers a result of 2.35 Mbits/secs

iperf3 -c 192xxx -i 1 -t 10 -R

Reverse mode, remote host is sending
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-10.00 sec 2.84 MBytes 2.38 Mbits/sec sender
[ 4] 0.00-10.00 sec 2.80 MBytes 2.35 Mbits/sec receiver

While the results seems a little more acceptable as a sender.

iperf3 -c 192xxx -i 1 -t 10

[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 144 MBytes 121 Mbits/sec 0 sender
[ 4] 0.00-10.00 sec 142 MBytes 119 Mbits/sec receiver

I use a dedicated Asus router RT-AX58U on a 5Ghz network.
I tried different position for the Vero4k+ with same results (no wall, etc.).

V4k+/OSMC is a great box and I would be pleased to find a way to solve this issue and to continue enhancing my personal media server. :slight_smile:

Any idea/support is welcome.


Can you verify that 2.4Ghz and 5Ghz are on separate SSIDs?

Dear Sam,

Nice to meet you and talking with you.
Yes, SSIDs are dedicated to separated networks.

It would be good to see some logs, so we can see if there’s anything obvious there.

The difference in performance based on direction is quite surprising.

Some more questions:

  • What’s the distance from the device to AP?
  • Is the device you are running iperf on also connected via WiFi?
  • Can you try run iperf against another device?



If you need specific log, please tell me, I will share them with you.

Regarding your points:

  • The device is 3/4 meters from the router.
  • The device running iperf as a server is connected to the same LAN, through WiFI, same SSID
  • The Vero4k+ delivers the same poor performances when communicating with another device (here located on an public iperf server):

iperf3 -c bouygues.iperf.fr -i 1 -t 10 -R

[ 4] 0.00-10.00 sec 4.57 MBytes 3.83 Mbits/sec 33 sender
[ 4] 0.00-10.00 sec 3.47 MBytes 2.91 Mbits/sec receiver

To compare the previous result, the same command line with any other device (from the lan to the public iperf server) delivers the following results:
[ 7] 0.00-10.03 sec 635 MBytes 531 Mbits/sec 0 sender
[ 7] 0.00-10.00 sec 626 MBytes 526 Mbits/sec receiver

Thank you

Do you have a local iperf server on wired Ethernet?

I don’t recommend using an external service to check network connectivity. Almost certainly, your upstream bandwidth will be lower than your downstream Internet bandwidth.

Ideally it would be good to see dmesg.

I have installed a wired Eth iperf server.
Here are the results:
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-10.00 sec 4.01 MBytes 3.36 Mbits/sec sender
[ 4] 0.00-10.00 sec 4.01 MBytes 3.36 Mbits/sec receiver

And, regarding the dmesg logs: here is the link

Thanks for your support

Your logs show this message every five seconds:

[  631.081992] Error getting the SSID

This is quite strange and I haven’t seen it before.
There is a newer WLAN driver in our 4.9 builds; but hopefully we can solve it on the stable 3.14 system.

  • What is the SSID of your WiFi AP?
  • Do you have VLAN enabled?
  • Are you able to try with another 5Ghz AP?

My guess is that the low performance is coming from blocking in the WiFi driver as a result of constantly trying to resolve the SSID.

  • My SSID is correctly matched at [ 7.309746] Connectting with a8:5e:45:10:41:24 channel (100) ssid “P80_5G”, len (6)
  • I do not use VLAN.
  • No.

Regarding your guess:
I have also seen this message when I was asked to check dmesg.
Apparently, there is no consequence on Wifi connection.
It comes from an application/service having, for some reason, a bad SSID to solve. :confused:

Dear Sam,

The SSID error came from wcid installation I did to investigate bandwidth issues.
I have removed it and rebooted the system.

I still have the same bandwidth issue (tested on a local eth iperf server).
I have updated the dmesg : here

Sorry for this inconvenience.

*** Test by using another router
As suggested, I managed to get another router for the purpose of this test: TP-Link AC1750

I have re-installed the same testing conditions:

  • iperf server on eth
  • 5Ghz dedicated SSID

At the end, here are the results:
[ 4] 0.00-10.00 sec 15.0 MBytes 12.6 Mbits/sec sender
[ 4] 0.00-10.00 sec 15.0 MBytes 12.6 Mbits/sec receiver

I have investigated memory, process, disk and network test activity on Vero 4k+.
And there is nothing of interest which could explain such behaviour.

Any suggestion on further investigation?

Maybe changing the channel helps. Otherwise I think it must be environmental.

You say you checked process, did you also check kernel threads for high CPU use?

I changed the channel bandwidth from “Auto” to “160 Mhz” and, now it works !
[ 4] 0.00-10.00 sec 202 MBytes 169 Mbits/sec sender
[ 4] 0.00-10.00 sec 201 MBytes 169 Mbits/sec receiver

I also checked the environment and forced the channel to 40.
Regarding the transfer rate, all iperf tests have been played with -i 1 -t 10

Now it seems that everything works fine, including 4k video through WiFi.

The origin of the problem was not a big issue but, to be honest, as the Vero was the only device with such bad transfer rates, I was pretty convinced it was the source of the issue.

I hope this case will help someone else.

I was very surprised to read your quick answer, your involvement and your followup.
Thank you so much for your support.

1 Like

I’m really glad to hear that this is solved.

As you can probably imagine, WiFi issues can be quite complex to diagnose and I am sure that after making this adjustment other devices on your network will still benefit; although it may not be as obvious if they are not streaming video