Lsusb command not found [SOLVED]

osmc@osmc:~$ uname -a
Linux osmc 3.18.9-5-osmc #1 SMP PREEMPT Wed Mar 11 18:59:35 UTC 2015 armv7l GNU/Linux
osmc@osmc:~$ lsusb
-bash: lsusb: command not found

I am accustomed to having access to this command on LINUX systems. Before I try to download any packages or make any system changes, perhaps there is an alternative or there something I am unaware of. Actionable suggestions and diagnostic questions are appreciated. Thank you

Install from apt.

apt-get usb-utils

Derek

1 Like

osmc@osmc:~$ apt-get usb-util
E: Invalid operation usb-util
osmc@osmc:~$ apt-get install lsusb
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission den
E: Unable to lock the administration directory (/var/lib/dpkg/), are you
osmc@osmc:~$ su apt-get install lsusb
No passwd entry for user ‘apt-get’
osmc@osmc:~$ sudo apt-get install lsusb
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package lsusb
osmc@osmc:~$ lsusb
-bash: lsusb: command not found

Not sure what else to try. Suggestions? I sense that I we are getting close.

sudo apt-get update
sudo apt-get install usbutils

6 Likes

Installing usbutils package in Debian:

sudo apt-get install usbutils

I appreciate everyone’s effort and contribution: it now works.

osmc@osmc:~$ lsusb
Bus 001 Device 004: ID 046d:c504 Logitech, Inc. Cordless Mouse+Keyboard Receiver
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

That being said, I tried each person’s suggestion, so it is unclear to me which commands were required to get to the successful state of things. That being said, I will disposition this thread as [SOLVED]

Again, Thank you.