Mac samba issues


I have the following issue when accessing an OSMC samba server from my Mac:

  • I used to (successfully) connect to specific folders on a OSMC samba server in my network from my Mac
  • access to these folders requires standard OSMC user and password
  • For the past week or so, I can no longer access these folders from my Mac
  • The samba shares and the folders are still visible in Finder
  • I can even still click on the folder, but they are empty when I open them, no files are shown (They are 100% not empty in fact)
  • I also cannot log off from this samba server. Clicking on Logoff in Finder doesn’t do anything
  • Access to the samba server and folders still possible with other devices I have

What I tried, to no avail:

  • deleting stored user and password to samba on my Mac
  • logging off from samba server in Finder and logging on using “Connect as…”
  • accessing the samba server via a different Mac user account
  • stopping and restarting samba in OSMC

Any ideas what I could try? Any chance this is an OSMC issue, or definitely a Mac issue?

Many thanks for your help!

MacBookPro Retina 15" Late 2013 - OS X 10.12.4
OSMC (latest version) running on Pi 2nd generation

It might be related to a current bug with auto mount template.
Please provide the URL of grab-logs -J -K -D

Try editing /etc/samba/smb.conf

Comment-out this line:
usershare template share = automount template

Let us first check the logs to determine if it is the issue

I connect my mac to my Rasp pi (running osmc) through SMB to transfer media files. The last few days I cant connect at all through SMB. I updated the SMB with sudo apt-get update / upgrade but it still wont connect.

I moved your post here which sounds like same topic

Thanks guys! My logs at:

HI @newbieuser
thanks for the log, as expected this is caused by a bug with automounted disks that have upper case letters in their file name. From here you have two options:

  1. Change all the disk labels to lower case, for different filesystems you would need to use different tools for that (I can advice if necesarry) and reboot afterwards
  2. Try what @anbodearg suggested

Also to help us figuring out what change cased this bug can you indicate when you problem started and also provide grab-logs -a


For some reason, I cannot browse my Externally mounted hard drives (Home and Willy) on my pi, BUT I can read and write everything to the OSMC folder over the network.

The hard drives work fine and play video on Russel (name of my pi) but I cant even view them over the network.

Both drives are HFS+ formatted, but installed the

hfsplus hfsutils hfsprogs

Picture here :

Hi @paulfischer I moved your post here as it most likely is the same bug.
Can you try to change the disk label of the drives to home and willy (all lowercase). And report if that fixes your problem.
Also would be great if you can let us know when the problem started and provide grab-logs -a

It fixed Home but it didnt fix Willy. He was corrupted and needed to be reformatted.

It hasnt worked since I began using it. Didnt start caring until April 9th I think?

So assume Willy is also fixed after you reformatted and renamed to willy, or?

Ok thanks, just to crosscheck when did you “began using it”? Seems you only joined the party earlier this year.

Yes. Both drives are in working order atm.

Yes. Probably in Feb? Before then I didnt have OSMC I had XBMC. It didnt work on that either.

This worked for me, many thanks guys!!!
I renamed the connected drives to lowercase names → problem solved.

Uploaded logs again in case this helps:

Thank you for the great support!

I have a new Vero 4K+.
I would like to manage the files on a microsd card inserted into V4K+

Samba server is on
From my Macbook I use FINDER to access my V4K+

I go to Finder > Go > Network
There I see the OSMC folder but when I click on it I get message
" The operation can’t be completed because the original item for “tv shows **” can’t be found.**"

I have no clue why “** **”” is seen

I then go to Finder > Go > Connect to server
Window pops open an I enter the IP address of the V4K+

Then I can see the the files and delete them