Major problems with the March update

It is an odd one. I just switched HDMI socket on the AVR, and after a few successful stop/start events, another black screen event, display then recovered by switching inputs back and forth on the remote. There has to be something in the March release that has caused this as all versions up until January are fine, and dropping to January fixes it. I will run a 3.14 Vero on the Jan version for stability, and see how the 4.9 platform develops on my other Vero.

There are no changes to the HDMITX subsystem in the March update.

Still looking in to this.

I am facing this issue too. with Denon AVR
started after update.

More on this: Problem after latest update with Vero4K+

Hello,

Since the March update on my Vero4k I have no sound anymore at all. Also the PVR plugin (tvheadend) has stuttering all over the place (for HD in mpeg4 and SD in mpeg2). I do not know that happened. Before everything was smooth with VERSION_ID=“2020.01-1”.

Is there anyway to downgrade without loosing everything?
Thanks a lot.

Cheers, stay healthy

You can re-install OSMC from https://osmc.tv/download, but it would be better for you start a separate post with logs so we can solve this for you.

Sam

I will try to do it. I will select the 2020.1 for reinstalling via SD Card.
Thanks for now

Btw: I tried to downgrade the kernel and got “failed to initialize EGL display (EGL error 12291)”. Because i previously had tried to switch to the new “videoimprovevero” channel ([TESTING] Linux 4.9 kernel and improved video stack for Vero 4K / 4K +). But it didn’t fix my problem…

If you install the 4.9 release, you need to reinstall OSMC to go back to the old kernel, as there are a number of changed dependencies.

Sam

1 Like

Thank you a lot for your fast feedback.
Just did a reinstall and now I am restoring my Kodi setting thanks to Backup plugin…
Luckily there is enough time now with Corona :wink:

I posted many logs to this thread regarding random blank screen events upon playback start or stop as a result of the March OSMC update. I have not been able to pin down a pattern for this. But when it happens, changing the input on my Marantz AVR to another source, and then switching back to the Vero, recovers the display. I thought I might post a log of the same behaviour under 4.9, as I’m keen to get this fixed in order for the Vero to have a sustainable future in my main system. I’ve summarised the exact sequence leading up to the blank screen event (in this case, I managed 7 successful start/stop events before the blank screen, normally the blank screen happens after fewer events than that).

The GUI is set to 60Hz.

Avengers bluray mkv start (60 to 24) - ok
Avengers stop (24 to 60) - ok
Live TV start (60 to 50) - ok
Live TV stop (50 to 60) - ok
DS9 DVD mkv start (60 to 59.94) - ok
DS9 stop - ok
Apollo 13 bluray mkv start (60 to 24) - ok
Apollo 13 stop (24 to 60) - blank screen, display recovered by source switching on the AVR

https://paste.osmc.tv/igiqucaxoc

I do not have this issue with any version of OSMC prior to March.

Hi,

The only thing that I can think of that could cause any issues like this would be the bootloader changes we introduced in March. But the bootloader won’t be downgraded on a re-install at the time of writing – so the issue should remain, even if downgrading, if this was the problem.

Your log shows that we switch back to 1080p60 correctly when you stop playing Apollo 13, so it seems like the AVR cannot lock on to the change for some reason.

We recently added some HDMI TMDS toggling changes to facilitate moving in and out of 3D modes. This is also included on the standard builds and I am wondering if this may be the cause of your problems.

I will produce a test build without these changes for you.

Sam

Please try this build:

wget "https://collab.osmc.tv/s/VyFLgAihekb5n0w/download" -O mediacenter.deb
sudo dpkg -i mediacenter.deb
sudo systemctl start mediacenter

Thanks

Sam

thanks for taking the time to look at this. I tried this build on a 4.9 V4K+ and it’s blank screening very frequently. Should I try on a 3.14 Vero?

You can use it on either kernel. 3D MVC will not work.

Just installed January OSMC on one of my Vero’s, no blank screen issues at all.

An odd thing: most of the movie thumbnails are not downloading from my mysql NAS database, but some are. All the TV thumbnails are fine. All the movies with missing posters have all the synopsis information, cast details etc. My Pi’s all connect to the same database and download all the movie posters instantly. This has never happened to me before with a reinstall of OSMC on a Vero. I tried deleting the userdata\thumbnails folder and starting again, rebooting the NAS, rebooting the Vero, but the poster download keeps stalling. Any ideas?

No, I would need logs for these issues.
It’s basically impossible for me to tell what is going on otherwise.

I also don’t know what you meant by blanking screen: during playback; on the menu; playing certain types of files?

the “blank screen” I refer to is the term I have been using in this thread in relation to the TV screen going completely black upon playback start or stop events since installing March OSMC on the Vero. These occur quite frequently with no apparent pattern. Sometimes the screen goes blank on a start event, sometimes on a stop event, sometimes it’s fine.

Here is a log of a Vero unable to recover the movie posters, some are present but most are missing.
https://paste.osmc.tv/legomacanu

I have put an OSMC Pi back into service for my main system on the March release and I get no blank screen issues at all.

It would be good if you could capture logs of that with the new build I have pushed. Your logs haven’t shown any dropouts so far and I’ve got no feedback based on the build produced a few hours earlier.

I would focus on resolving the other issue first.
Did you copy your Kodi userdata over or is this fresh?

This reads a bit like apples and oranges — I’m not sure how this will be relevant, unless you aren’t playing any 4K content on the Vero (obviously you can’t on the Pi) are using the same cables and have the same video mode output (pixel clock and VIC) , same adjust refresh rate setting, same Kodi settings, same HDMI cables connected to the same ports on the AVR and TV.

I assume it’s still the case that if your AVR is removed, the problem goes away.

it’s as apples-to-apples as I can get it. I remove the Vero, connect the Pi to the same HDMI cable and hence input on the AVR, all Kodi settings accessible via the GUI are the same. Will follow with a log from the test build on a Vero.

If you can cover the other points too, that will be good.
Failing that – you remark that it works on January build. We could upgrade January piece by piece to March and see what happens

Sam

Here is a log from a V4K+ on 4.9 kernel running the test download. I went through the same stop/start sequence as per a few posts before, this time the blank screen event happened sooner in the sequence (it tends to be a bit random)

Avengers start/stop - ok
Live TV start/stop - ok
DS9 start - ok
DS9 stop - blank screen, changing the AVR to another source and then back to the vero recovers the display.

https://paste.osmc.tv/ulenoxagum