Make OSMC more reliable


#1

I have more than one TV in the house and only one is in a comfortable place to sit and set up the Pi. Why not make OSMC do like Raspbian and check video before loading so we can move an OSMC box to different TV’s and have them work. Ei between one with CEC and one without?

Joe


#2

OSMC does poll hdmi connected devices at boot for supported resolutions.


#3

I don’t really understand the request


#4

I think the OP means not start the mediacenter service (Kodi) if no display is detected.


#5

Are you saying your Pi with OSMC works on TV1 but not when moving the Pi to TV2 which has a different resolution? Please clarify!


#6

Yes, one tv has CEC other doesn’t. Loading OSMC from NOOBS mediacenter works ok . Loaded from the installer, this TV goes black and stays black when MC starts. Same if I bring it up and set it up on the CEC TV and move the box to the other, MC is black. I can bring it up if config.txt has hdmi_safe=1, but so far experimenting, no other way. The CEC TV is a Viso 4k TV and the other is a Viso 1080 HDTV (2009 model)

Edit: This is incorrect. Loading OSMC from NOOBS no longer works. I originally did this back in March NOOBs so something has changed.


#7
  1. Do you need CEC on the second TV? Why not completely disable CEC in OSMC?

  2. Do you need multiple operating systems or NOOBS at all?

This isn’t connected to CEC in any form. As @ActionA stated above, OSMC does poll hdmi connected devices at boot for supported resolutions except you set something in the config.txt the other TV couldn’t handle.

First, please backup your config.txt and revert any changes you made to it in the first place. Second, please revert any changes you made to OSMC concerning fix resolution.

Out of the box OSMC will work perfectly on both of your TVs.


#8

Did you notice when I said a fresh install from the installer results in a black screen? I use NOOBS for dual boot with Raspbian.

PS: The one set up on my other TV has over 2000 movies in it’s database which is why I tried to clone it.


#9

Done experimenting…Setting hdmi_safe=1 till I put a new TV in there…Mark “solved”


#10

This is almost certainly a hardware issue specific to you and not wide spread. I would test with different HDMI cables to start.


#11

If it were that, why would Raspbian come up fine?–Solved for now with safe mode. This cable worked with the dual boot I had before, that crashed.


#12

This isn’t a reported issue with OSMC.
It could be a NOOBS bug.

Raspbian uses an X11 desktop, so it’s different in behaviour.

Sam