Make OSMC Windows installer work on high DPI devices

Just downloaded it to reinstall my 4k+ and it’s awful.

I use a 4k XPS13 and scaling set to 200%. The installer does not like this at all, drop downs too small to read the text in them. Can’t read the versions available to install until after selecting.

Needs fixing as Win 10 and high DPI devices are pretty common these days.

This is something we’ve had many requests to support over the years, but I don’t know how to implement it. I’ve asked for some help with this but none has been forthcoming.

For now you can use the compatibility tab to make the program work as expected. We could produce a manifest.xml fixup to resolve this, but no one gave any feedback on test builds so far.

If no one comes forward then it’s probably just easier to remove the installer and suggest a different tool.

Is it just writing an disk image to the memory stick? Win32DiskImager is what lots of others apps recommend. One thing less for you to maintain as well :grinning:

I disagree. For the vast majority of windows users the install is a quick and easy method of installation. The vast majority of PC users out there are not running 4k resolution on a 13" screen and this is more of a Microsoft issue than OSMC IMO.

There are also preseeding capabilitie which are useful and will be expanded with the next version of My OSMC. But that version of the installer will be deprecated by then.

Unfortunately some users find Win32DiskImager too hard to use: they don’t know to extract files etc.

All we need to do is set DPI awareness in the appmanifest.xml (which is already shipped): https://docs.microsoft.com/en-us/windows/win32/sbscs/application-manifests. But I am unable to produce this DPI issue on a Windows 7 box at 200% scaling. I don’t have a Windows 10 system available for testing on.

I am willing to test the new installer. I have a Win10 x64 with 4K monitor.

Can you reproduce the problem however?
We don’t need to even re-compile the installer. It should be as simple as follows:

  • Download the EXE
  • If you have WinRAR or WinZIP installed, extract the EXE archive to a folder
  • Edit the application’s manifest.xml. We need to tweak this. It’s not clear to me what the exact settings are yet, but for Windows 7/8.1/10 it should probably be:
<asmv3:application>
<asmv3:windowsSettings xmlns="http://schemas.microsoft.com/SMI/2005/WindowsSettings">
  <dpiAware>false</dpiAware>
</asmv3:windowsSettings>

This should tell Windows that we can’t handle DPI scaling and give the same effect of compatibility.
I already tried setting this before but to no avail. I will download a Windows 10 VM for testing now and try reproduce.

@darwindesign has tested the solution.
I will build a new version of the installer shortly and update this thread.

Thanks @sam_nazarko I’ll give it a check when it’s ready :slight_smile:

@darwindesign not sure what field you work in but for developers it’s pretty common, plus gamers. Screen size is irrelevant. MS has provided the relevant options etc since Win 8 (maybe 8.1) to deal with DPI. Win 10 sorted the bugs around different DPI settings on different displays.

Anyways, nice one Sam for sorting so quick :slight_smile:

We could’ve fixed this four years ago if someone had volunteered to test, which is quite a shame…

At least it will be solved now.

Yes they have but apparently going to the properties of a application and selecting a different scaling option is too much for some people as judged by this thread. I helped Sam fix it anyway. Your welcome.

Please test this updated version of the installer: https://collab.osmc.tv/s/0rQOqC4BrkET0Zm

Sam

Seems to work OK when I tested (Running on 4k Screens)

Fine on mine. Except Windows kicked in and said it was Untrusted and wouldn’t run, had to click More Info to be allowed to install. Presume it needs a known Publisher?

No - it probably just hasn’t been downloaded enough times to be trusted yet.

Makes sense, thanks again for sorting :slight_smile: