Make the volume change and not 100% all the time!

This is a feature request for the upcoming updates, and I´ll hope we can solve this real quick.

Using my Nexus 6P as remote with the app Kore as remote, and all is working fine and dandy except the volume buttons.

We are facing 2 small bugs with this:

  1. When you connect a new phone, the volume popup for how high the volume is refuses to fade away and is always visible. To “fix” this, you need to reboot the RPi for it to go away.

  2. The volume is always 100% no matter if you are increasing or decrasing the volume.

  1. Sounds like a very rare bug that I’m not aware we’ve ever seen before. Possibly an issue with Kore itself or something as simple as the skin you are using. You’ve provided very little info with which to attempt to pursue an actual cause.

  2. Are you saying that adjusting volume within Kodi is not working? Are you using passthrough? If you are, then this is the expected behavior.

This error is still here, and the developers of the app Kore are not going to help me with it. They are telling the problems is in OSMC and how OSMC is handling the volume.

Will record a video to show the bug and hope for the best!

Than I suggest you post your bug report on the kodi forum http://forum.kodi.tv/

Sorry, my bad!

The problem is in OSMC and not in KODI!

How do you determine this?

How have you determined that the problem with a remote app integrating with the kodi software is because of the underlying operating system (OSMC).

Please turn on debug logging, reboot your pi, recreate the problem and upload debug logs as described in the article below.

You can learn more about how to submit a useful support request here

So, here it goes:

Pastebin http://pastebin.com/SkQ1ceX3

And a video for proof https://dl.dropboxusercontent.com/u/70405647/VID_20170215_192004.mp4

In the video I adjust the volume up and down and still it shows 100%!

Is the volume actually changing and simply reporting 100% in error?

I still don’t see how this is not a Kore issue.

1 Like

And confirmed, this is only a gh0st problem…

.Vidme

Not an OSMC problem. Nor a Kodi or Kore problem. I’d suggest a complete reinstall for you.

Enjoy! :wink:

Can’t see due to forced to install flash!

Another problem unrelated to OSMC…

.Vidme
The video shows OSMC and Kore operate as expected. The problem is your install.

Good luck.

Wiped it and reinstalled with a brand new install yesterday! Still same issue with the volume always stuck at showing 100% no matter the real volume is.

Then the question is, whos problem it is?! The Kore team don’t want to own it, because they tell me it’s OSMC’s problem. And OSMC don’t want to own it.

It’s a freaking bug, but a small one.

If you are the only person to suffer from it, then it’s not a bug until you can prove it’s a bug. If no one else can reproduce the problem then it’s up to you to find out why it only affects you. Sorry…

Can you tell us how to reproduce the bug reliably?

To reproduce the problem

Latest OSMC running on a rPI 2 model B.
Latest Kore app running on random Android phone.

I lifted this bug to the Kore team https://github.com/xbmc/Kore/issues/226 but Kore is not the problem regarding to them.

Nope, can’t reproduce by following this procedure. All devices function as expected (see previous video).

In your github issue, you were advised to report to Kodi forums.