Makemkv + compiling for osmc

As per a few posts over at makemkv and this one in particular:

There is now a working arm version of makemkv which allows the playback of all encrypted blurays by Kodi.

However as the post notes there is a bit of cross matching of versions to get it all to work properly with osmc.

The post notes it could be cross compiled for arm64/armhf and I think would then work without needing to compile separately on a Pi4 with a 64bit OS.

Are the any Linux gurus out there who might be able to give me some pointers on what I would need to do to cross compile makemkv?

I figure at the configure stage (or add a configure stage) I need a “–enable-cross-compile” and then a build and a target/host?
When I get the time to do all necessary backups I may give it a go myself but some pointers before would be welcome even if it’s only an educated guess.


And for anyone who doesn’t know what makemkv is/is for the paid for program is for making backups of blurays and such. But it’s been In beta for a long time and with a beta key it can be used on Linux to play Blu-ray’s in software replacing the standard Blu-ray decryption libraries.
The current key is good till September 2022 and I think they just publish a new key every so often which is likely to continue for some rime
I checked how much it is and it’s like £50 to purchase which is a bit steep but if I could get it working and after a year or two it goes out of beta it might be worth it to play all my blurays in kodi? Maybe?
Technically should be able to support UHD too.


Can you please clarify your requirements?

I’m aware of MakeMKV and know that people use it to rip their BD discs.

Usually the choices for most people with a collection are to rip an ISO (we can play encrypted ones if AACS keys are provided; but cannot provide them for legal reasons) or to rip using MakeMKV.



Ok so my requirements and desire to use MakeMKV on my Vero4k is so that I can watch Blurays on my Kodi box without having to worry about whether or not they can be decrypted.

Currently I have a tmdbhelper player file setup and I will “Play from Bluray” which creates the correct movie information and then will play the disc with the art/info/correct scrobbles etc.

If it doesnt decrypt I will play a bluray which does, and let Kodi do the scrobbling and then watch the actual bluray I want to watch on my samsung bluray player.

But I’d much rather know I can just always use Kodi and would only need to fall back to the full bluray player when I need menus. Also its a BDXL drive which could possibly support UHD Bluray.

I was able to get Makemkv to compile and get the correct libs installed (which needed to compile a separate version on a PiOS Buster 2021 64Bit image) as per the post I linked to.
But it can’t recognize the disk because it cant read it using the SG module.

Compiled as per the previous post.

So while I can point it at the folder the disc is mounted against without being able to correctly ID the disc it then cant decrypt it.

You can already do this by installing some AACS keys. We already build libbluray with AACS support.

I’ve got KEYDB.cfg setup but it only works with about half of my blurays.

I’m currently trying to see if I can get the bdplus cached tables properly setup as per here:

And AACS KEYDB.cfg from here:

But when I have tried it previously only the AACS decoding appeared to work.

I think those cached tables only work for libbdplus > and I think the osmc version is on (not too sure about that though)

Anyway I just tried it after having downloaded the bdplus vm0 and convtab files and it still isnt working for a newer(ish) bluray.

So my test discs have been the Stark trek trilogy, Star Trek and Into darkness play fine but Star Trek Beyond is encrypted.

So i am hoping I can use makemkv and the to do the bluray decryption in place of “” and “” but this only works (now there is an armhf/arm64 makemkv bin compiled) if it can access the drive on /dev/sg0

OK, I’ll look at getting the SG module support in shortly.

Ok so I can confirm with the latest kernel updates on the testing branch that the SG module has been enabled and can be started:

sudo modprobe sg

And I have also tested makemkv and it also appears to now work if you follow the instructions:

1 Like

So following the posted instructions I was able to get a couple of blurays to play which I wasnt able to before.

Still unable to play Star Trek Beyond, says its encrypted while the makemkvcon can access the disc. Im not sure if i’ve previously locked the disc out somehow? That was my go to test encrypted disc when ive been attempting stuff so i may have tried decyrpting it with an aacs keydb.cfg which had been blacklisted? I believe it works something like that.

But I tried The Predator, which previously had played but only as music, so this time it actually started. And a couple of other discs which had previously not played due to encryption and they started.

So makemkv can be used to play blurays and very possibly UHD on vero 4k. My drive supposedly supports it according to the forum post I checked.