Mantistek WA150

I have bought a Mantistek WA150 wifi/BT USB adapter it needs rtl_bt/rtl8723b_fw.bin as firmware which is in firmware-realtek package

I run 17.6 on strech release

sudo apt-get install firmware-realtek
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
Need to get 0 B/342 kB of archives.
After this operation, 1,147 kB of additional disk space will be used.
(Reading database … 25816 files and directories currently installed.)
Preparing to unpack …/firmware-realtek_20161130-3_all.deb …
Unpacking firmware-realtek (20161130-3) …
dpkg: error processing archive /var/cache/apt/archives/firmware-realtek_20161130-3_all.deb (–unpack):
trying to overwrite ‘/lib/firmware/RTL8192E/boot.img’, which is also in package wireless-firmware-osmc 1.1.4
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:

Any idea how to get round this?

Well you could try sudo apt-get remove wireless-firmware-osmc and then try to install your firmware package. But are you sure it is not on the osmc firmware package?

As you’ve probably guessed, firmware-realtek is trying to install a file that’s already been installed from the package wireless-firmware-osmc. Only one package can “own” that file.

I’d be more inclined to extract the file and copy it over to /lib/firmware, leaving the OSMC package intact.

dpkg -x /var/cache/apt/archives/firmware-realtek_20161130-3_all.deb ~/rtlfw
sudo cp ~/rtlfw/lib/firmware/rtl_bt/rtl8723b_fw.bin /lib/firmware/rtl_bt

(You might need to create the rtl_bt directory.)

I have copied the rtl8723b_fw.bin file to the rtl_bt directory and bluetooth came to work great!
Bus 001 Device 005: ID 413c:2003 Dell Computer Corp. Keyboard
Bus 001 Device 004: ID 0bda:b720 Realtek Semiconductor Corp.
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp. SMC9512/9514 USB Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

[NEW] Controller 40:A5:EF:D2:D0:0A radio1 [default]

Module Size Used by
cmac 3070 1
evdev 14201 1
bnep 12304 2
btusb 31543 0
btrtl 4916 1 btusb
btintel 11034 1 btusb
btbcm 8008 1 btusb
bluetooth 443640 26 btrtl,btintel,bnep,btbcm,btusb
rfkill 25020 3 bluetooth
snd_bcm2835 23623 0
snd_pcm 116882 1 snd_bcm2835
bcm2835_thermal 2435 0
snd_timer 28031 1 snd_pcm
8021q 22606 0
garp 7794 1 8021q
stp 2218 1 garp
llc 5918 2 garp,stp
snd 79233 3 snd_timer,snd_bcm2835,snd_pcm
iptable_nat 2328 0
nf_conntrack_ipv4 8616 1
nf_defrag_ipv4 1753 1 nf_conntrack_ipv4
nf_nat_ipv4 7234 1 iptable_nat
nf_nat 19355 1 nf_nat_ipv4
nf_conntrack 105822 3 nf_conntrack_ipv4,nf_nat_ipv4,nf_nat
iptable_mangle 1900 0
bcm2835_gpiomem 3751 0
iptable_filter 2184 0
uio_pdrv_genirq 3846 0
uio 10256 1 uio_pdrv_genirq
fixed 3029 0
ip_tables 13466 3 iptable_mangle,iptable_filter,iptable_nat
x_tables 24533 3 iptable_mangle,ip_tables,iptable_filter
ipv6 439492 40

Wireless does not work yet should I copy all of these to /lib/firmware? (from the .deb file)

Replying to my own post. All works now. I have compiled and installed the correct WIFI driver for the dongle.
Took a while to understand connmanctl to configure the WIFI but it works happily now. Result is that I have WIFI and Bluetooth working through a singe dongle.

What I hope to get through Bluetooth is a bit better audio.

Greetings and thanks for the help.

This thread was originally about installing the correct firmware for the device.

So for the benefit of others in the community, could you tell us:

(a) which firmware you ended up using; and

(b) which source code you eventually used for the driver?

Hi, i would like to ask how you were able to compile this driver for mantistek wifi-bt module because on latest osmc i endup with error:
make ARCH=arm CROSS_COMPILE= -C /lib/modules/4.14.78-4-osmc/build M=/home/osmc/drivers/1/rtl8723au modules
make[1]: Entering directory ‘/usr/src/rbp2-headers-4.14.78-4-osmc’
CC [M] /home/osmc/drivers/1/rtl8723au/core/rtw_cmd.o
In file included from ./include/linux/netfilter.h:8:0,
from ./include/linux/netfilter/nf_conntrack_tuple_common.h:6,
from ./include/linux/netfilter/nf_conntrack_dccp.h:29,
from ./include/net/netns/conntrack.h:11,
from ./include/net/net_namespace.h:27,
from ./include/linux/netdevice.h:42,
from /home/osmc/drivers/1/rtl8723au/include/osdep_service.h:51,
from /home/osmc/drivers/1/rtl8723au/core/rtw_cmd.c:23:
./include/linux/if.h:28:54: fatal error: sys/socket.h: No such file or directory

  • on lwfinger · GitHub i see more sources for this chipset but everyone give the same error as above

Please see Has anybody tried to install Wireguard? - #28 by dillthedog for details of a workaround to your problem.

The source code can be found here.