Manual resolution settings

I connect my Pi2 through a receiver so most of the time, OSMC doesn’t seem to detect all of the available display modes my TV supports. I also have both a TV and projector on the output from the receiver on an amplified splitter. I imagine this kills off some smart options? The only refresh rates I get this way on fullHD is 50Hz or 60Hz.

The only way to select the mode I want to use us to rummage around the cables and connect the Pi2 directly to my TV, where I suddenly get all the display resolution and refresh rates available to pick from.

Ideally I’d like to be able to override what OSMC detects available and pick 1920x1080@24, for example.

To explain a little, the 10m HDMI cable between my receiver and projector can’t handle full HD at 60Hz reliably.

1 Like

You can set an hdmi_mode in config.txt

To expand on Sam’s answer a little bit, in the Pi Config module in the OSMC settings addon you can choose hdmi_group (CEA or DMT) and hdmi_mode which is a number. Refer to the table on this page for all the numbers:

You probably want hdmi_group 2 (CEA) and hdmi_mode 32 which is 1920x1080p at 24Hz.

1 Like

DBMandrake, You mentioned the OSMC settings addon. Where can I find this addon? I have a 1080i display and I thought I would have to modify the config.txt file but if there is a settings addon that I can utilize that would be better. If there isn’t a settings addon can you give the directory location of the config.txt file?

Thanks, Mark

I found the setting on mine in Apps > OSMC Settings (KodeKarnage 0.0.1)
In there I go to “Pi Config” and selected the “hdmi_ignore_edid” option.

I now have all resolutions available on the OSMC display settings and all refresh rates. It waits for you to verify any change so unless you blindly OK something you can’t see it seems safe.

Pugwash, I don’t think I’m finding the option that you are referring to. Is it possible for you to send me a screen shot of the option? Is 1080i in the list are you select the hdmi_ignore_edid option?

Thanks, Mark