Manual update from OSMC, broke my kodi (RC1)

I did a manual update from kodi today, and now my system wont boot up.
I get this error:

and the network interface doesnt load up as well so i cant ssh to it from my pc…i have to switch monitor cables all the time trying to find a solution on the net…
Any ideas? Executing the above commands doesnt give any good info either.

i am re-installing the whole thing…grrrrr

I can see one major problem there - the file system is apparently read only. Not sure how that would have happened but it will definitely cause major problems and failure to boot.

What does the output of mount look like ? And the output of dmesg ?

Also you don’t say what device you have OSMC installed on (Pi 1/2, Vero) and whether you have an SD install, USB or NFS.

yeah sorry about that. Its a pi2 8gb sd card…everything on the sd card no HD connected to it.
I tried to find some info on how to debug this but couldnt find any.
I had a backup of my system (a month old) so now i am restoring it…
I’ll do the update again after it boots…hopefully i’ll get the same errors and post the results.

restored my backup and manual updated again…all went well…weird bug before…dont know what messed it up.

hmm same thing happened again today…for no reason…the pi was working fine yesterday.
Today a kid pressed the buttons on the remote and when i switched the tv to the pi to see if he started a movie or something the picture was frozen inside a movie with the left sidebar open.
After restart i got the Failed to start LSB errors again, and the Samba server error under it.

Is it possible that the SD got corrupted ? I mean totally messed up ? no matter how many restores i make it will always do that?

It sounds more like there is a hardware fault, most likely a bad SD card.

It’s not normal at all for the filesystem to drop into read only mode, and thus far you’re the only one to report this problem.

I would try a different SD card.

Could it have something to do with the wifi option in the GUI that says “Wait for Network” ?
Since last time that this problem occurred it was the only thing that i enabled.

Thanks again for answering :smile:

Maybe this will help? That’s the only errors I see from dmseg

No, wait for network will not cause your filesystem to go read only :wink:

I don’t see any relevant errors in your dmesg log either. You really do just need to try a different SD card. If disk errors are occurring it will cause all kinds of random problems, and you are just wasting your time looking for a software solution to a hardware problem if the SD card is indeed faulty.

One thing i forgot to mention was that the OSMC logo screen is also distorted when the pi boots. That was right out of the .img file i had. (my backup after installing osmc with everything i wanted)
So maybe the .img file was not done properly before, and now restores keeps giving me errors ?
I think i’ll go back to my USB stick system…and use the SD only for boot.
I mean how unlucky will i be if those 30-40mb needed on the SD to boot from the usb was damaged as well :stuck_out_tongue:

just had the same thing yesterday. I tried to manually update from RC1 to RC2 via GUI but nothing happened after selecting the manual update function. I then used ssh and did apt-get update and apt-get dist-upgrade, but the upgrade process got stuck after 5-10 minutes (i waited another 10 minutes but nothing happened). I had to disconnect the Pi2 (8 GB SD) from power to reboot. After rebooting I had the exact same symptoms. Using dist-upgrade would say that the system was in read-only mode. I tried sudo dpkg --configure -a as suggested, but it would say that the system is locked and in read-only mode. Trying to delete the dpkg lock file would also only give the message that the file system is read only.
In the end I did a clean install, which worked fine again.
If there are not many more people experiencing something like this it was probably a corrupt SD card in my case as well.

1 Like

but its weird that this problem started with both of us doing manual update from rc1 to rc2.
The alpha4 version was working fine. I didnt many custom stuff to it without any hiccups.
Isnt it weird that both SDs got corrupted at the same time doing the exact same thing ?
My .img backup that i made was after i did the manual update from rc1 to rc2…so maybe i keep getting the same error because the img ‘picked’ up a bug in it and it just keep repeating itself.
I think we should try backup up our .kodi folder and do a clean install on the SD then FTP the .kodi folder back and see what happens.
I think the rc1->rc2 process is leaving garbage behind that breaks things.

Disconnecting the power in the middle of an upgrade could well cause enough filesystem corruption to cause it to mount read only. It’s possible it might have needed fsck running manually, although that would be unusual.

If you were running the update from the command line you could have pressed CTRL-C to abort it rather than just pull out the plug. Or even if you couldn’t get control back you could have opened another SSH session and used the reboot command to do a graceful reboot. (Which wouldn’t corrupt the filesystem)

What’s possibly happened is that you started the update process in the GUI, but got impatient and then tried to run it manually even though it was still updating in the background via the GUI. This would cause one of the two update processes (possibly both) to hang waiting for an APT lock.

You need to be patient checking for updates - especially the first check after install and especially on a Pi 1. The first update check after install on a Pi 1 can take almost 5 minutes from the time you choose to check for updates until it will start installing them as there is no pre-loaded apt cache on a fresh install so it has to download and process the entire apt archive.

When you initiate a manual update it will tell you with a dialog box when it is complete with no updates found, or has updates to install. If you didn’t receive such a dialog box you didn’t wait long enough and it was still processing the update in the background, and by starting another update process you interfered with the first one.

I just did a clean install with a full swipe of the SD card, so I cannot reproduce the error or produce some log files. I know I am not being very helpful, but I sometimes I am a bit too impatient. Anyways, I am using the backup addon, so a clean install is not too much wasted time.

I didnt pull any cable or did it through console (both times that i upgraded manually).
Everything was done from the GUI. I just went to the Manual Update tab in the Settings.
After the update i got the message “Do you want me to install the update” and i hit yes, it did its things, when the pi rebooted itself and then i got the error message.
I know i could have done it from the console but i trusted the GUI would do a better job :slight_smile:

Thanks for the clarification. CTRL-C did not do the trick, but of course I could have started another ssh session. Did not cross my mind.
Just for future reference: If I press the manual update button in the GUI, what should happen exactly? Should I see a dialog saying it is searching? Or will I see nothing and then only a dialog after 5 minutes as you described?
Because in my case there was no dialog at all after pressing the update button. It looked like the system did not do anything.
I will work on my patience issue and have some logs handy next time.
By the way, it is a really nice and powerful piece of software. Apart from a few minor annoyances it is absolutely perfect and i use almost on a daily basis (What can I say? I am German, we just like to complain a lot.).

When you press the Manual Update button from the gui you should see box at the top right corner in kodi parsing the files been downloaded and any unzipping and installing of packages.
Also there is a progress bar and download speed and how many mb are left for the current package.
In the end a popup window shows the option to install the update (with a Yes, No type of questions).
If you press Yes, (i think, if i remember correctly) the pi reboots and gets you in a DOS type of window showing the update progress.
After that the pi reboots and everything should go back to normal.

Thanks, next time I press the button and nothing happens I will have a look at the logs.