March 5th update broke xbox DVD dongle

Hi since the last update my remote control is not working anymore. Mouse is tough
I tried re-selecting Xbox DVD dongle in osmc settings. Also tried rebooting

Help please

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Are you using a TSOP?

Ok I will upload a log soon

I am using a vanilla Xbox DVD dongle rewired to USB plug with harmony 650 remote control. It worked until I pressed update. After update rpi3 booted, then sad face (I don’t know why but it always seems to happen after an update) then it rebooted automatically and remote wasn’t working.

Tried rebooting again
Then tried to reselected Xbox DVD from osmc settings. Still not working.

Rebooted again. Not working.

I am using a mouse for now

What is tsop?

How are you getting signals from the remote?

USB Xbox dongle

Here’s a log

I cannot see anything except the log date in that - how did you create it?

Check if dmesg shows Xbox module being loaded (lirc_xbox).

I updated this driver in 4.14:

Unfortunately it’s not maintained upstream and I don’t have a dongle to test with. A GPIO based TSOP may also work for you.

turned on debug then rebooted then upload via osmc utility

here’s the file on pastebin

dmesg log is empty
not sure how to look for that

quick update

i’ll try to restart with a fresh install and see how it goes

Same issue here, oh the woes of deciding to update lol

OG XBOX DVD remote and dongle

My dmesg:

ok so a fresh install of january version restored remote. reupdated to february and remote is broken again

so definitely a problem with february update

and also noticed that i don’t have ssh access either

I’ll send you $25 if you think that’s enough to obtain a dongle/remote and an xbox to USB adapter. Well worth keeping my remote working haha

Just upgrade your PuTTY install

i will try that!

thank you k0usi it worked for putty

here is my dsmeg

(dsmeg osmc -

i have found this line

[ 5.065586] usbcore: registered new interface driver xpad
[ 5.067741] lirc_dev: IR Remote Control driver registered, major 243
[ 5.117329] lirc_xbox: module is from the staging directory, the quality is u nknown, you have been warned.
[ 5.118732] lirc_xbox: module is from the staging directory, the quality is u nknown, you have been warned.
[ 5.119154]
lirc_xbox: XBOX DVD Dongle USB remote driver for LIRC $Revision: 0.01 $
[ 5.119158] lirc_xbox: Jason Martin
[ 5.119246] lirc_dev: fops pointer not filled in!
[ 5.119287] lirc_xbox[5]: inbound endpoint not found
[ 5.119331] usbcore: registered new interface driver lirc_xbox

and it is about the same in k0usi’s log

I have the same issue, using a Harmony 950 but my context menu buttons do nothing, normal buttons, play pause etc work ok

When you say it’s the ‘same issue’. Are you using an Xbox dongle?
If not – then the issue is not the same

1 Like

any hints sor far?

by the way thanks you for helping