March update switched to software decoding

I just applied the March update and now when playing videos my Vero 4k is using ffmpeg software decoding, giving high cpu usage, video artifacts and lagging and passthrough audio keeps dropping.


Try to update again the issue should be solved now

No updates available, looks like I updated after that was posted

This is happening to me as well.

I was watching a 4K movie about 10 hours ago and it played/sounded fine.

I came back to the Vero 4K about 30 minutes ago and was notified that an update was waiting to be done. Allowed the update and have this exact problem. I have now turned off the automatic updates.

The problem is so bad that it is impossible to watch any 4K movies as I have tried a few.

Can I not go somewhere and download last months version to install?

We have to wait for a new Vero4k kernel image.
Sorry for this inconvenience.

How long is that likely to take? Basically my living room TV is now useless :frowning:
Can we roll back a version?

I can confirm the same problem here. am on version .68
What are the timeframe for this new kernel.

I confirm the same too: no HW acceleration for any media (H264, H265)… all my media is playing vía software decoder and its unwatchable (affects too to playing LiveTV vía tvheadend server and pvr.hts).

osmc@Vero4K:~$ sudo systemctl status systemd-modules-load.service

  • systemd-modules-load.service - Load Kernel Modules
    Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static; vendor preset: enabled)
    Active: failed (Result: exit-code) since Sat 2018-03-17 11:10:32 CET; 11min ago
    Docs: man:systemd-modules-load.service(8)
    Process: 169 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
    Main PID: 169 (code=exited, status=1/FAILURE)

Mar 17 11:10:32 Vero4K systemd-modules-load[169]: Failed to find module ‘amlvideodri’
Mar 17 11:10:32 Vero4K systemd-modules-load[169]: Failed to find module ‘meson-ir’

Looks like kernel modules aren’t loading.

I just installed the Feb update and my audio and video are back to normal.
This is the first time I have done this as I am not an experienced user by any means. I can pronounce and spell Kodi but that is where my knowledge of it ends. lol.

I followed the instructions in the wiki here: Reinstalling OSMC - Vero 4K - OSMC

I just use the Vero 4K to watch video from external HDD’s. I have no ‘libraries’ or the like so doing a reinstall was straightforward. I don’t know what would happen with other setups but I suspect you would have a lot of work to do to reinstall ‘things’.

I have turned off auto-updating so not to be caught out like this again.

I’ve had a lot of practice with this recently. I downloaded the installer for my Windows PC, and use that to create a USB stick with the desired version, then plug that in to the Vero and reboot. You can backup your settings from the Vero MyOSMC utility and then restore, or start from scratch, depending on how much time that would take. If you backup settings to a network location, you may need to reinstall Samba first and copy the backup file across to /home on the Vero manually as I could not see network locations in the restore utility.

In my case, the installer is confusing, as the only option from the list is SD card, the radio buttons do not work. But on selecting SD card, my USB drive then becomes available as a target for writing the OSMC image. I’ve now got the whole process down to around 10mins

1 Like

Darn it, wish that was mentioned in the Wiki as I had to use a micro SD card from something else, wiping data off that. Perhaps the author of the Wiki could ‘update’ it!
I see that the Wiki mentions USB but I was fooled by not being able to select it as the SD was the only one that is able to be selected.

Thanks for mentioning about the uSB option coming available. :slight_smile:

This question is about “Where would you like to install OSMC” means where do you want the final OS to be install to not the Installation Image.
As the Vero4k currently only allows installation to the internal emmc all other options are greyed out and are only available for the Raspberry Image.

So, no USB can be used, only micro SD card?

No, seems you didn’t understand what I tried to explain. That choice is about where the final OS is going to be installed to not the installer image. The target for the installer image can be choosen on the next screen which shows you your SD Card or USB stick.
I agree that screen might be confusing as it shows SD card while for the Vero4k the installation target actually will be the emmc but this installer predates the Vero4k by 3 years.

Thanks for your reply. Let’s see if I understand this correctly. Can I put what I put on the micro SD card that I booted the Vero 4K from, on to a USB stick and use that instead of the micro SD card?


Thanks for the explanation. But for a new user, I think the obvious interpretation of the screen shot I posted is that the options are referring to the installation media, not the end-stage home for the OS. Clearly I’m not the only user who was confused by this at first. Would be good to get the installer updated at some point to help new users.

1 Like


I came to report this, is there any timescale on it? Currently have 3 unusable vero4ks.

I think an easy “in OS” way to roll back to a previous version is a no brainer at this point surely.

No issue here but I noticed that my Vero4k had three updates in the last 24h or so, which made me visit the forum to check… guess I already got the fix.