MCE IR remote key mapped to different actions

Hey guys,

I got this cheap remote from ali-express, lsusb shows: Xenta SE340D PC Remote Control
I am using version 2017-10-1 of OSMC, on a RPI 3.
The remote control came with a USB IR receiver.

Now the remote kinda works out of the box, but there are a few problems:

  • When watching a movie, the fast forward key (like, playback speed x2, x4, x8, x16) will activate the ‘FastForward’, but also ‘StepForward’ 10sec actions. After doing some tests and activating debug mode and check the logs, it seems like pressing the FF key activates about 2-3 actions simultanious. (being: the ‘right’ key, the ‘f’ key and also the ‘mod=ctrl+shift f’ key…
  • The power off button acts like it’s being pressed continuously, like: the pop-up window appears, dissapears, appears etc…

I’ve tried changing some key maps with the kodi add-on, but to no avail. I also looked into the default keyboard.xml keymap, but I wonder if it has to do with this, since pressing the key seems to be interpreted as multiple keys. Could this be a IR receiver problem?

Any ideas are welcome. And if you require more info, feel free to ask!

Some remotes unfortunately send multiple key presses per single press. This makes them hard to map

right, so if that’s the case there is no way to ‘filter’ these?
I can recall that before using osmc, on raspbmc or openelec (not sure which) the remote worked just fine.
No lirc config or something like that to adjust in order to filter the right input?

You can of course record your own LIRC profile. A search on this forum will cover how to do this