Me TV add-on; videos do not load or run

The Me TV plugin will show updated menus, and it’s possible to select episodes of shows, but will not run. It suggests I check the logs. Now, to begin with, which logs should I send to you for diagnosis? (I have uninstalled and re-installed the plugin; no change. Have also done manual updates. Still no joy. I can run videos from sources like Cracker and YouTube, no problem.)

Brief hardware description: Raspberry Pi B, 512 MB, CanaKit power supply which works, wifi, peripherals are WiFi and USB flash drive, OSMC running off Micro SD card, MPEG2 and VC1 codecs, HDMI video output.

Info on obtaining logs can be found here

But what you are saying seems to indicate an issue with the add-on. In that case it should be reported to the add-on developers, not OSMC. MeTV Plugin

I left a message to the plugin’s author. Here’s the conversation:

Thomas Reed Wrote: I am in the United States. I do have the logs I mentioned, and they are at this address:

I’m new to this, so I’ll have to figure out how to unzip the file and
put it into OSMC. I’ve only loaded plugins from the repositories OSMC
puts up.

The author replied: No idea why it doesn’t play, but I can tell you it’s platform related.
From your log, the addon is resolving to the correct url and I’m able to
play it from Kodi on windows and Android.

I’m not familar with OSMC, you may want to ask the folks in the know of that platform.

So now you have the URL for my logs. Do you see anything in them that would cause OSMC not to play it? (The ZIP file is the author’s suggestion to try an earlier version of the MeTV plugin, but I don’t know how to add a foreign plugin file to OSMC. Are those directions someplace?)

Seems okay here (using a debug build of kodi). Possibly a network issue. Can you ssh in and run:


if that looks okay try playing the file from kodi.

Okay, I put Putty on one of my Windows machines and could ssh into my OSMC machine. I ran the command line you sent. It apparently downloaded a clip. Now since I’m a noob, where did it download the clip? To the root file system of my Pi’s SDHC card? To a “download” folder? Since I don’t know where or if OSMC puts these, and since it has no apparent file browser to show directories, how do I navigate through OSMC to find where the heck the clip is? Again, your help is appreciated.

Run “pwd” to see the current directory. You can then browse to that in kodi.
Use video menu and “add files”

I’m sorry to keep pestering, but I don’t understand this. And the documentation on the site is limited. I know that OSMC is running on top of Kodi. So how do I get out of OSMC and get to Kodi? And then, how do I get back?

Turns out I didn’t need to get to Kodi, although instructions to get to there through OSMC might be handy. I still didn’t find where that video test file went; will see if the link can download to my Windows system and will run off a flash drive.

Meanwhile, over at the Kodi forum for the MeTV plugin, the developer gave a link to an earlier version of the plugin. It still didn’t play, with again the admonition to check the log files for the errors that occurred. The developer did note that the URL’s to get to the MeTV posts are valid. Here are the log files after that last run:

If there are no other solutions, I may have to nuke and pave, installing a fresh version of OSMC. (sigh)

OSMC is a stripped down Linux version dedicated to running Kodi. The media center app that runs on boot IS Kodi. Kodi is running on top of OSMC, not the other way around

Okay, well, nothing seems to be working. I’m going to nuke and pave the SD card and see if a new installation works better. Just glad I kept the email with my decoder unlocks. Let you know how it works, and if it keeps working.

All right. I nuked the SD card, reinstalled OSMC and the codecs, and loaded the YouTube video plugin. The short promo clips, all of them 30 seconds, seem to play okay. But again, any of the program clips chug along (with the spinning circle acting in a jerky, non-smooth fashion) and the sign “please check logs” comes up again. I have the new log of this posted at:
In a few days I’ll have a video posted to YouTube that shows what happens when I try to play videos in the MeTV plugin. (This is the plugin that automatically installs with the new installation of OSMC.)

I just installed and tested MeTV on my Pi2 and it’s working fine here. Do you have Kodi installed on another PC? Does MeTV work from it? Possibly an internet lag issue?

Okay, for you to see what’s happening (and possibly suggest a solution) here’s the YouTube video that shows the problem. MeTV Plugin Problem - YouTube

Do you have a windows/mac you can install kodi on and then to install metv addon and test there on the same network?

if that does work please go back to OSMC and try again and send som new logs.


Okay, problem SEEMS to be solved. I had to reboot my cable modem and wireless router. i have MeTV again. It seems that there was some borderline situation with the MeTV server that it required a reboot. Thanks for the help, guys. Now what I need to see is how I can set up OSMC on the Pi so that it has a dedicated address. (I’ve been letting the router assign the address to the Pi, and maybe there might be a conflict there.)