Media frame stutter with UI set to 1080p. Bizarre

So this is a weird one. For some reason, when viewing most media with the Vero UI set to 1080p/60, the frame-rate is uneven, not smooth etc. There’s no reported skipped/missing frames by Kodi, but my own eyes don’t lie. This is true of 1080p/24 movies and 2160p/24 movies that I’ve tested. I’ve set playback to match display, so that’s not it.

Oddly, if I set the Vero to 2160p/60/50/24, - I get no such issues in movies, and they all run flawlessly. Has anyone else seen this? It behaved this way with the October, 2022 build, and nothing has changed on the Jan, 2023 build.

Hardware: Vero 4K+ connected to Samsung HW-Q990B soundbar → LG CX OLED.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Yep, momentary lapse. Here’s the log. Only needed the first 10 seconds of a movie file. lohotiqema

Adjust display refresh rate: On start / stop

Can you change this to Always?

Yes, I tried that. Makes no difference at all.

I see the issue.

I can see Kodi is searching the whitelist for 1080p23.976 and it can’t find it, so it stays at 1080p60 which would cause stuttering

You can disable whitelisting in Settings.

Interesting. You’re correct. Not sure how that happened, or how to put 1080p/23.976 or 1080p/24 back in… Help? :sweat_smile:

Confirmed on the TV, if I leave the UI set to 1080/60 it stays at 1080p/60 for 24p movies. That’s the issue. If I set the UI to 2160p/60 it switches to 2160p/24 for movies, even 1080p ones, and it’s all nice and smooth. Just not sure how to resolve the problem.

You don’t need to enable whitelisting. We leave it off by default.


Well, more info. Connected the Vero to my LG CX, bypassing the Samsung HW-Q990B soundbar. Those resolutions now show up and it works. However, when going through the soundbar (which I have to do), there’s no 1080p/24 refresh rates available. So odd. All 4K refresh rates are available, as mentioned earlier. Wish I could figure out what’s going on here.

Well… I confirmed it. The Samsung HW-Q990B does not support anything less than 50hz at 1080p. I guess you can’t expect anything special for a flagship 11.1.4 Atmos soundbar. Thanks, Samsung! No choice but to run the Vero UI at 2160p, so 24p works properly. Sheesh.

Cheers for the help, Sam/ActionA.