Mediacenter auto restart loop after 2021-08 upgrade and library scan

Hello, my Vero4K upgrade to 2021-08 initially went well and we watched some videos, enjoyed better performance. But after 1st library scan today, mediacenter is restarting directly just a few seconds after the GUI main menu is displayed.
I got into SSH, stopped mediacenter, enabled debug level 2, restarted the mediacenter and got the kodi.log file.[](

Any advise on how to resolve this?
Would of course like to avoid a full reinstall.
I have an OSMC backup from before the upgrade.

Upgrade was done as follows

  1. OSMC Backup taken through MyOSMC
  2. MyOSMC upgrade run manually but failed on Debian connection error. Tried with and without VPN, no difference
  3. Ran the upgrade from SSH command line with apt-get update, dist-upgrade and autoremove
  4. Rebooted the Vero4K
  5. Once in the Mediacenter, could use it as normal (Aeon Nox Silvo skin), though some addins disabled as not compatible with Kodi 19.1. Played a few videos from network drives and a streaming service working very well, faster performance than 2020-11 release
  6. Ran the library update today. A few secs after it ended, mediacenter restarted with sad face, and entered into the restart loop (restarting Mediacenter, not rebooting the whole Vero4K)


Please upload full logs (grab-logs -A or via MyOSMC Log Uploader) so that we also see the kodi.old.log and the surrounding configurations.

But from a quick look I suggest first to try removing the none standard Kodi Repositories and respective Addons to see if that help.

Thanks. Full logs are here

For removing non-standard repositories and add-ons or any other suggested solution, please advise the way to do that through SSH command line, as the GUI is not available due to the continuous restart.

Ok one of the issues seems to be Library Data Provider. You should be able to get the system initially going with rm -R /home/osmc/.kodi/addons/

Afterwards maybe check this Kodi Thread which is discussing the issue

Hello, yes GUI is more stable now. But when navigating to certain titles in the Video library it crashes. Indicates that the thread you are pointing to might have the right root cause. Will try that, thanks!

Hi, after troubleshooting using the thread you pointed to it seems the issue is related to special characters (Swedish Å, Ä, Ö) in the file path or filename in the database records cannot be handled properly by the new OSMC release after the upgrade.
Whenever I try to play e.g. a movie added in previous OSMC version library from the Movies view from the main menu, Kodi says the file does not exist and ask if I want it to be removed from the library.
Then when a video scan is done, it tries to add again the same movie files that already exist in the library. The new records created have an invalid “BLOB” field value in the path or filename in the MyVideos119.db file, if the path or filename contains a special character.

I removed those records from the DB, and OSMC / Kodi is now back to the stable status seen after the upgrade.

But any file with special characters in the filename or path registered in the database by previous release cannot be played, and trying to add them by the video scan will create a corrupt record.
But playing the same movie file through the Files menu / Filebrowser in Kodi works perfectly fine!

Anybody has any inputs how to resolve this issue, seems the be a character encoding issue between Kodi Matrix and its DB?

Or how I can roll back to previous release. I have a backup…

I don’t think this is a general issue but specific to the Library Data Addon and/or the Aeon Skin with the use of NFO files. For me the suggestion is you continue following the development on the Kodi Forum as it is surely a much better source of information.

That would be done via a reinstall using the October Image from the installer.

I agree the skin and the Library Data Addon seems to be the culprits here.
However, I did not have any nfo files, so this is not exactly same issue though pointing to special characters.

Note also I installed Kodi Matrix 19 from scratch on an Android TV with the same Aeon Nox Silvo skin and same NAS data sources as the Vero4K, and it worked fine.

With the family asking “when will the TV work again”, it seems fastest way is to make a clean Vero4K install with latest release, rather than wait on the Kodi thread to conclude…

That’s an interesting find. Would be interesting to compare the 2 database files. Or even what would be interesting if you use a shared MySQL database for the 2.

Yes, agree. Though need to figure out how to get the DB file from a Sony Bravia with built in Android TV :slight_smile:

Update: Could not manage to get the DB on the Sony Bravia without going for rooting etc.

Instead went for full wipe and clean install of the Vero4K. Added the same data sources, my key add-ins, but stayed on the OSMC Skin. Almost everything working fine.

  • files with special characters in path or filename can be played after added to the library. I see that the special characters are removed "e.g. /långfilm/ becomes /lngfilm/
  • due to this removal of special characters any file with special characters in path or filename must be manually added to library after typing the special character for the parser scanner to find it in TMDB

Haven’t attempted the Aeon Nox Silvo skin with the Library Data addon, but cannot see why it should not work if it worked on the Android TV Kodi instance.

As there are quite a high number of users in Europe especially also in the team that tested V19 since day 1 I am really surprised here.
Can you explain where do you see such removal? In file view? This would surprise me as you use fstab based mounts.

Hi, I see that in the GUI when looking at Information screen of a movie in the library, scrolling to see the filename and path.

But now I had a look in the DB. And it seems in the movie table, movieview table etc, any filename or path with special characters has a “BLOB” hexadecimal value in the DB instead of a readable string.

Will try to install Library Data addon and see what happens…

I can not reproduce that here. I just created an entry with långfilm and it found by TMDB and shows correct.

Screenshot from 2021-08-30 18-51-42

The key differences with the Android TV instance is that it does not use fstab to mount the NAS shared folder through cifs/Samba, but instead uses the Kodi SMB client.

So I did a test setting up a new folder Långfilm on the NAS which I added as video source on the Vero4K using the Kodi SMB client. And that worked perfectly as it should - special characters recognised when scanning the folder and the Movie DB file gets a correct record instead of a BLOB. Screenshot from the DB browser, first row generated by the fstab mounted source, second by the SMB client source.

But as far as I am aware, fstab gives better performance, so I should use that, right?
Is there something I can do to adjust the fstab parameters to get issue resolved?

Current parameters
// /media/NAS/media cifs user,guest,sec=ntlm,noauto,x-systemd.automount,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

Update: Issue resolved.
I applied the fstab settings as per this thread Configuring fstab based Samba share mounts
Main thing missing was I had not explicitly specified the iocharset to utf8, which was now needed to get the special characters to work

After this the parser no longer creates BLOB records

I will delete and rescan the BLOB records, then install the Aeon Nox skin.


1 Like