MediaTek wireless dongle not working (RPi 1 B+)


#23

The mt7601u driver exists on OSMC and supports the VID/PID of the dongle (148f 7601).

osmc@osmc:~$ modinfo mt7601u
filename:       /lib/modules/4.14.78-4-osmc/kernel/drivers/net/wireless/mediatek/mt7601u/mt7601u.ko
license:        GPL
firmware:       mt7601u.bin
srcversion:     D06F3ABB275F34B500D150A
alias:          usb:v7392p7710d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2A5Fp1000d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2955p1001d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2955p0001d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2717p4106d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2001p3D04d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v148Fp760Dd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v148Fp760Cd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v148Fp760Bd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v148Fp760Ad*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v148Fp7601d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v13D3p3434d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v13D3p3431d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0E8Dp760Bd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0E8Dp760Ad*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0B05p17D3d*dc*dsc*dp*ic*isc*ip*in*
depends:        mac80211,cfg80211
intree:         Y
name:           mt7601u
vermagic:       4.14.78-4-osmc SMP preempt mod_unload modversions ARMv7 p2v8

#24

Ignore me – I completely forgot that it had been added…


#25

Did you try OSMC again since fixing your power issues?

Sam


#26

Yes, but it still doesn’t recognize the WiFi adapter


#27

Looking around, this is (or was) a common problem.

It’s discussed here with a possible fix posted by one contributor ingate.


#28

I’ll look into that! I tried the dongle in a few other of my Pi’s. They recognize it and it works but then it cuts out, so I’m thinking it might be drawing too much power through USB? I’m using an actual AC adapter (not charger) that puts out 5V 2A.