MediaTek wireless dongle not working (RPi 1 B+)


#1

Hello all,

I bought this dongle off eBay and it arrived last night: https://www.ebay.com/itm/232565785508?ViewItem=&item=232565785508

I plugged it into my Pi and OSMC does not support it, apparently. Is there a driver that I can install for it to work? I have it plugged in Ethernet currently but it’s rather inconvenient. I do not have a model number for the dongle but I messaged the seller for it. I’ll post back once I’ve heard about it. EDIT: After some googling I think that its model number is MT7601U. I’ll update if it’s not the case.

Here is the log: https://paste.osmc.tv/ozaduhecoc

Thank you for any and all help!


#3

Did you unplug and replug it several times while testing?
Is your power supply up for the task?


#4

I tried again using a Moto Turbo charger just to be safe, so the power supply isn’t the issue. After I restarted I tried unplugging and plugging back in every other USB port. It still didn’t take. Here is the log file for that experiment:

https://paste.osmc.tv/ovicilefaz


#5

Chargers are not the right power supplies to power the Pi, get a proper Pi powersupply.
You can learn more on our Wiki here: https://osmc.tv/wiki/raspberry-pi/frequently-asked-questions/


#6

@fzinken
I am now using a 5V 2A power supply. The wireless option still isn’t even showing up.


#7

What is the log showing? Still continuous USB disconnects?


#9

Yes.

https://paste.osmc.tv/icagosepak


#10

For me that still looks like the stick disconnects either because of power issue or something else messing up. Did you tried the stick in another device?


#11

I am using the stick right now on my Windows laptop to make this post, so it’s working okay on this. It worked immediately on plugging it in. I’ve never had power issues with the Pi previously.


#12

I ordered an actual 5V 2.5A power adapter and it should be arriving any day now. I’ll give that a try. I still cannot get Kodi to recognize the WiFi adapter.

Any insights/suggestions are welcome.


#13

My insight is to have you let us know if a proper power supply fixes the problem.


#14

@bmillham @fzinken No, a proper power supply does not fix the problem :confused:

I apologize for the incredibly delayed reply. Life was crazy over the past few months.


#15

Could you provide full logs again. The previous ones have expired.


#16

https://paste.osmc.tv/oyocuzavot


#17

What are you using as a power supply now? You last comment was that you had ordered a ‘power adaptor’. Can you give a link to what you ordered?

You log shows that it’s seeing the WiFi, but not able to fully communicate with it.

How about trying a powered USB hub?


#18

Sure thing:


It’s 5V 3A.

I’ll have to get one of those. I’ll try it out and see how that goes


#19

Hi,

Looks to me like the seller has not listed it correctly, if it is indeed a charger it won’t be constantly providing the 3 amps. I suggest getting the offical Raspberry Pi power supply; I suspect the issues you are facing will go away. Should try:

https://www.raspberrypi.org/products/raspberry-pi-universal-power-supply/

or

https://osmc.tv/store/product/raspberry-pi-power-supply/

Thanks Tom.


#20

I’m pretty sure the seller listed it incorrectly as a charger. The paperwork included with the adapter only talks about it being an adapter supplying constant power, not a charger. I’ll still eliminate the margin of error by getting the official adapter. I’ll try that after trying the USB hub, but I have to get through Christmas first :wink:

Thank you all so much for your assistance!

Lukas


#21

Quick update:
I got another Pi I have up and running. It was originally running on Raspbian Wheezy but I updated it to Stretch and it recognizes the WiFi adapter just fine. When it was on Wheezy it didn’t register the WiFi adapter. When I plugged in the WiFi adapter on Stretch, the USB hubs lost a lot of power (I couldn’t use my mouse or keyboard). I shut off the Pi, plugged in the power adapter pictured above, and all the USB power works flawlessly and the WiFi adapter works perfectly.

Tl;Dr - I think the power adapter is fine. Am I just missing a driver or something? I can’t find one. From what I can tell it’s a MediaTek (RealTek?) MT7601U


#22

Hi,

That driver is not supported under OSMC at this time.

Sam