Memory consumption constantly rise


#1

Hi Guys,

I would like to share with you about a problem that I encountered that I can’t resolve on my own (at least so far)

I have raspberry pi 3b with osmc installed.
In addition I installed:

  • openvpn (and configured it to connect to ivaccy vpn server)
  • qbittorrent
  • radarr
  • sonarr
  • fail2ban (with the permanent ban after 3 login attempts)

Everyting seems, at first sight, works well, but after a couple of hours, my RAM (kodi) usage jumps from +/- 300 MB to 400+. After then goes to 500 then go to 600 etc. Usually, there is some crash in the end.

Memory rise even when there is no activity (nothing to download), no one is watching video etc.
So basically my system is ready to works only for 1-2days before memory will be full.

Any idea or suggestion for a newbie like me?

my logs are here:
https://paste.osmc.tv/ofikojiyak

my debug logs are available under this link
http://paste.osmc.io/puqutizage.vhdl

Thanks in advance!


#2

Try disabling the services one at a time.
I suspect it will be Radarr or Sonarr.

Sam


#3

Sure, I will but on the process list - kodi is highlighted as a process that cosumes more and more memory, while the memory consumption on sonarr and radarr is more or less on the same level.


#4

If the other processes doesn’t grab more memory after running for a while, then perhaps there is some kodi addon that is stealing memory?


#5

Definitely, I will try with add-ons later today.
After switched off services of radarr and sonarr memory went from 400 MB to 288 MB, But after night my memory usage is again around 500 MB.
So neither sonarr and radarr are here to blame (qbittorrent is a service that I installed two days ago, and the problem occurs for weeks, so I can exclude it as well)

My logs are here
https://paste.osmc.tv/nuvoyusiwe

My logs are here


#6

I see that your log is full of errors caused by qbittorrent-nox and smbd. I’d try disabling those and see if the problem clears up.


#7

Hi,

I disabled most of addons. But this dosen’t help. Then decided to disable qbitttorent with no sucess. At morning I disabled samba service, but from 7 am to now ( 6 pm) memory rose 120 MB .

BTW is there any way to “reset” kodi to default state (all addons and repositories set to default state) ?

Recent logs are here
https://paste.osmc.tv/coliwugage


#8

log in with ssh, run this command

systemctl stop mediacenter
mv .kodi .kodi-backup
systemctl start mediacenter

that will completely remove all addons and repositories, if you want it back then do the same just reverse the .kodi .kodi-backup, like this “mv .kodi-backup .kodi”


#9

Guys,

Tried above method to reset kodi. Installed only one addon to watch aljazeera
Except that is “pure” kodi.
But problem hasn’t been solved.
I’m sure that despite errors in logs it’s not related to torrent and samba (both were disabled for some time with no success).
Any idea? Any other additional logs that I can provide ?
My current log after kodi reset is here (but from yesterday 400 MB, today is 650).

https://paste.osmc.tv/ehiwifazis


#10

#13

#14

Little update.
I think that my osmc system has almost halted so tried to restart mediacenter - from ssh - please see below

osmc@osmc:~$ systemctl restart mediacenter

** (process:7486): WARNING **: Unable to register authentication agent: Timeout was reached
Error registering authentication agent: Timeout was reached (g-io-error-quark, 24)
Could not watch jobs: Connection timed out


#15

Hi,

If You disable the one addon you’ve added, does the memory consumption still rise?

If it was me I’d try kodi on fresh sdcard, no addons and monitor.

Thanks Tom.


#16

Yes, it still raising :frowning: Slowly but constantly.
I try to avoid format all option, as I don’t know what is the root of the problem, and I can stuck with the same problem again.
And a lot of stuff is already configured (dyndns, fail2ban & other mentioned services like vpn).
But eventually I will try to format card and install it again


#17

I meant try it on a new sd card, this and pure kodi. If there still an issue, then it will most likely be the hardware.

Thanks Tom.


#18

I reformatted card and installed it again.
I will update info as long as I will test new installation properly :wink:


#19

Problem still persist. It’s better then before, but definitely memory is not all the time on the same level.
I see that in “idle” it’s quite good (it’s raise about 20-30 mb per night), but when I do anything on it memory raise and doesn’t want to lower even after activity stops.
I tried to implement kodi switch after powering off TV, [HowTo] for auto quit/start kodi based on TV status but it doesn’t help either.

My current logs are here: https://paste.osmc.tv/keledomuzo


#20

Hi,

NOTICE: Disabled debug logging due to GUI setting. Level 0

So hard to say what the issue is.

It looks like a couple of plugins have been enabled, do you still the high consumption if you disable these. One of these could be causing the issue.

As I previously advised I would try a new sd card as well.

Thanks Tom.


#21

The first thing I would advise OP to do is remove the Indigo addon from TVA plus any other trace of them or their addons from their system.


#22

The sensible way to debug this problem is to start with a very basic installation of OSMC – what Tom referred to above as “pure Kodi”. You should not install any Kodi add-ons, skins or external packages until you are sure that the problem is no longer there. Then, one step at a time, change the configuration of Kodi and properly test it for stability before moving to the next step.